Support » Plugins » [Plugin: Yet Another Related Posts Plugin] Database Failure & Cache emty

  • After I upgrade the YARPP Plugin today, the plugin doesn´t work anymore. In the Admin Panel i have this 2 messsages:

    Your related posts cache is empty. Please build your cache from the related posts status pane

    Die YARPP-Datenbank hat einen Fehler, der nicht behoben werden kann. (The YARPP Database got an Error, which can not be fixed)

    If I want to build the cache, this message apperars:
    Related posts cache status: 0%
    There was an error while constructing the related posts for

    so, what shall I do, to get this plugin working like befor the upgrade?

Viewing 15 replies - 1 through 15 (of 19 total)
  • I have the same problem ! 🙁

    How desinstall completly YARPP ?

    @klijan – Can you check your SQL db to see if there are two tables named wp_yarpp_related_cache and wp_yarpp_keyword_cache? If those two tables are not there, then it looks like your WP db account doesn’t have access to create those tables like it needs to. Were you using YARPP 2.1.6 before?

    @moimm – to uninstall, just deactive the plugin from the plugin settings page and then remove the folder from the server.

    Thx for your quick answer (and sorry for my bad english ! 😉

    I have see my SQL db … and i don’t see the two tables !

    For info > I have used YARPP 2.1.6 before !


    @mitchoyoshitaka: thanks for you reply. Yesterday i have try about two hours to get this plugin working like before. with no result.

    Then i have decided to delete it. i have deactivate the plugin und remove the folder. After that i have search via mysql for yarpp and it show me some tables with yarpp. i have deleted this tables an i hope this was right.

    @kiljan – sorry it didn’t work out with your setup. The 2.1.6 is still available for download.

    @moimm – if you look at the HTML source of the YARPP options screen, do you see a couple lines of HTML comments like <!–YARPP error: … –>? This is some debug information which may help figure out what went wrong. Do you know if the db user WP is using has access to create new tables or not?


    Sorry, i don’t know if the db user Wp use a access to create new table ?
    How i can to know it ?

    Maybe i can create the table manually, if you say me what i must to do (i’m noob in db manipulation !! 😀 😉 )

    I go to read your html comment in the HTML source ! 🙂

    mitchoyoshitaka … i don’t find your <!–YARPP error: … –>? html comments ?

    Where i can find it ? In the code source of a file (i have open many php files and find nothing 🙁 )

    I have the same problem as MoiMM.
    The tables are missing in the db. Other plugins have created tables so the db user should have sufficient access.
    The HTML source of the options pages does not include any YARPP errors but there are 4 MySQL errors:

    <!–MySQL-Fehler beim Hinzufügen von “yarpp_title”: –><!–MySQL-Fehler beim Hinzufügen von “yarpp_content”: –><!–MySQL error on creating yarpp_keyword_cache table: –><!–MySQL error on creating yarpp_related_cache table: –>

    Firebug also throws this:
    Access to restricted URI denied” code: “1012
    [Break on this error] eval(function(p,a,c,k,e,r){e=function(c)…

    I don’t even know if this is related 😉
    I’d really appreciate a fix for this problem.

    I am having the same problem.

    I installed the latest version of the Yarpp plugin (3.0.4)on my WordPress Blog(latest version 2.7.1).

    Unfortunately on the Yarpp Options page I get an error message indicating that the Yarpp database cannot be fixed. When I attempt to set the yarpp cache the process stops almost immediately and I also get an error message. When I look at the WordPress
    database I do not see the Yarpp tables that should have been installed.

    I am wondering whether anyone has a possible fix for this problem. I have seen this plugin working on other blogs and I think it is great. I am very keen to get it running on my own blog.

    Many thanks.

    I have the same problem. I assume that this error is due to an older version of MySQL. I don’t think the create statements are compatible with MySQL 4.0 (I have that in use). Creating the tables by hand (after removing certain utf8-settings and current_timestamp) worked for creating the cache, but not for using it. I stopped there and took the latest version.

    I have try the last version (3.0.4) … but it’s again the same problem !

    I have re-install the 2.1.6 version and now that work normaly !?!

    I don’t know why … but i have find only this solution for that work … 😕


    Hi all— I’ve decided I’m going to make a page on my YARPP site which lists the SQL queries to be run in case the automatic queries don’t run (for example, if your WP database user doesn’t have the right permissions). I’ll post a link when it’s up.

    Hi all— here’s the list of the SQL queries required for YARPP installation:

    Thanks for your last post but for those of us who have absolutely no idea what those instructions mean or how to implement them, can you offer some alternative advice?

    I have both the wp_yarpp_keyword_cache and wp_yarpp_related_cache tables visible but get the cache build gets interrupted at 48.4% everytime I try to build the cache. I get the following message; “Constructing the related posts timed out.”

    The plugin is still visible on my pages, see an example ..

    .. but I don’t know how effective it is.

    Appreciate any help.

    @funkster – are you actually getting the “there was a database error that could not be fixed” message from YARPP?? That’s what those instructions are for. If you are able to build the cache (even partially) then you most likely have no need for the manual SQL setup.

    If you’re having trouble completing the cache, I recommend you simply keep the “on the fly” caching option on. Over time it will naturally build up your cache and there should be no need for you to manually build it.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘[Plugin: Yet Another Related Posts Plugin] Database Failure & Cache emty’ is closed to new replies.