Support » Plugins » [Plugin: Yet Another Related Posts Plugin] Customizing Output

  • After removing the ol and li tags in the settings and adding only a comma (,) in the after each entry setting, I get a list of all related posts as a continous sentence-style list separated with commas. But as expected, there is a trailing comma.

    How do I remove this trailing comma?

    (See an example of this here on this page under the heading Related Posts)

Viewing 9 replies - 1 through 9 (of 9 total)
  • @exchequer598 – Hmm… good question. I don’t have a quick fix for you… the only thing I can think of is using a CSS pseudoclass like :first-child to hide one comma, but that’s definitely not ideal… I’m sorry I don’t have a good answer for you, but I’ll keep it in mind for the future.


    @ mitcho:
    Thanks for the response. I’m planning to launch my blog in a month. So I’ll be waiting for you :D. Also, check out Rob’s Similar Posts plugin ( which implements the feature I asked for.. Well.. Partially. It introduces an annoying linebreak after every comma, which pretty much defeats my entire purpose. You can see its output in the page I’ve quoted in my 1st post here!

    Maybe you can find the solution for my problem in that plugin (which is HUGE by the way!). Thanks for the help!

    Hi mitcho. I see that 2.1.4 doesn’t support my request. Can you please include it in the next release? Pretty pleeeees!

    Sorry @exchequer598 – The next major revision (most likely the next revision, as long as 2.1.4 doesn’t have any critical bugs I need to quickly fix…) of Yet Another Related Posts Plugin will let you do what you want to, with some basic PHP. This upcoming revision will introduce a new templating feature which lets powerusers uber-customize the display of each related posts, in the same way you can write templates for WP itself–indeed, using those same commands.

    “Yet Another Related Posts Plugin” works perfectly in my blog. I love it.

    The number of related posts that appear are set to 5 by default.
    I need to increase the number of related posts displays to 10.

    I am new in this plugin stuff and I appreciate it if some one could kindly help me identify which file and line I need to edit.

    I tried to edit the “includes.php” file:

    $yarpp_value_options = array(‘threshold’ => 5,
    ‘limit’ => 5,

    I changed the “limit” to 10 and/or the threshold to 10, but no change in the number of displays. Perhaps, I need to change additional numbers somewhere else?

    Please help.

    @keddy – There’s no need to edit the default options in the code. Just go to your wp-admin and go to options/settings > Related Posts (YARPP). You can then adjust all the settings you want to right there.

    @ Mithco,

    Thanks for the post.

    I did try to change the settings (Treshhold and/or max number of displays) to 10 (and also tried 7). But, instead, I got “No Related Posts”.

    I am running WP 2.7, perhaps 2.7 is not compatible?

    Until I changed the settings to 10 or 7, the related postings worked fine.
    Now, I put them back to the default settings (5, 5), but still displays, “No Related Posts”.

    Please help.



    Not sure what happened, but now 10 related posted are getting displayed. I am really very happy.

    Thank you so much for this creative tool.

    Best regards,

    @exchequer598 – I just released YARPP 3.0 beta 1 and wrote up a tutorial on the new templating features, including a demo on how to do the inline display as you requested. ^^ Thanks for the suggestion!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: Yet Another Related Posts Plugin] Customizing Output’ is closed to new replies.