WordPress.org

Support

Support » How-To and Troubleshooting » [Plugin: Yet Another Related Posts Plugin] Comments don’t show

[Plugin: Yet Another Related Posts Plugin] Comments don’t show

Viewing 10 replies - 1 through 10 (of 10 total)
  • Hmm, odd. YARPP should not be affecting the comments display at all… Are you displaying using the “automatically display” option or by inserting the <?php related_posts() ?> code in your template? If you’re displaying automatically, try disabling that option and inserting that code into your theme.

    derFrankie
    Member

    @derfrankie

    Hi,

    I actually had the same problem on 2 separate blogs. The one I mentioned above is with automatic, the other I’ve inserted the function realted_posts(); – with the same result.

    How can I help you to find the problem?

    Are the related posts by chance the last thing to be produced by PHP in the page’s source? If it is (and output stops after it) it most likely is a PHP error… could you check your PHP error log and see if you’re getting any errors from YARPP?

    bookworm316
    Member

    @bookworm316

    I am having the same problem as well. No matter what I change, the plugin seems to block out comments. Any update on the fix?

    I am also having this problem. I updated from 2.x to 3.0.5 and comments stopped showing up. When I deactivate YARPP, everything is fine.

    There are a bunch of messages like this one in my error_log:

    [27-May-2009 15:16:56] WordPress database error You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-1' at line 1 for query SELECT SQL_CALC_FOUND_ROWS wp_posts.*, yarpp.score FROM wp_posts join wp_yarpp_related_cache as yarpp using (ID) WHERE 1=1 AND wp_posts.post_type = 'post' AND (wp_posts.post_status = 'publish' OR wp_posts.post_status = 'private') ORDER BY wp_posts.post_date DESC limit -1 made by require, require_once, include, the_content, apply_filters, call_user_func_array, yarpp_default, yarpp_related, include, WP_Query->have_posts, do_action, call_user_func_array, Pager_hook, SEO_pager, query_posts, WP_Query->query, WP_Query->get_posts

    Okay, it’s definitely caused by a conflict between SEO_pager and YARPP (for me, anyway). When I activated YARPP and deactivated SEO_pager, everything returned to normal.

    bookworm316
    Member

    @bookworm316

    Your right eppsilon its SEO_pager. For me I just shut off the the automatic code implementation in it and comments came back fine. Very strange

    bookworm316
    Member

    @bookworm316

    When I unchecked the auto insert feature in seo_pager and just added the SEO pager code manually it works fine now. The pager shows up and the comments are still there.

    derFrankie
    Member

    @derfrankie

    Great @bookworm316 – this fixed it for me as well.
    Thanx

    I’ll add this to the FAQ.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin: Yet Another Related Posts Plugin] Comments don’t show’ is closed to new replies.