Support » Plugin: Yet Another Related Posts Plugin (YARPP) » [Plugin: Yet Another Related Posts Plugin] Building the cache

  • My installation seems ok (templates return ‘consolation prize setting with a valid post’ but there are no posts showing with even the lowest settings, it’s clear there is no cache. I’m on 3.1.9. I’ve deactivated, reinstalled and there’s always an error message
    “The plugin generated 202 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.”
    Should I try the new beta?

    http://wordpress.org/extend/plugins/yet-another-related-posts-plugin/

Viewing 15 replies - 1 through 15 (of 16 total)
  • may be because there is space before php code.

    Well that’s not true, There’s a very healthy wp_yarp_keyword_cache in the MySQL but it doesn’t want to play with me.

    Can’t see any spaces before code in the edit windows
    Thanks for the suggestion

    Is there anything in the wp_yarpp_keyword_cache and wp_yarpp_related_cache tables?

    While I was waiting 🙂 I tried to change the CSS of the theme to remove yarp but gave up because it mucked up too much. Last week I’ve done an upgrade to the beta 3.2b2. There was a filled cache, now I can’t see any yarp tables at all.
    The plugin activates but when I try and change and save the settings there’s an error
    Warning: array_search() [function.array-search]: Wrong datatype for second argument in E:\webspace\regionalfood.com.au\httpdocs\cooks\wp-content\plugins\yet-another-related-posts-plugin\includes.php on line 428

    If there are no tables now, that could explain the error, You mention manually adding the db tables is that an option.
    Thanks
    Fred

    The theme is WP-Mediamag. website is http://www.regionalfood.com.au/cooks/

    I would recommend using the latest version, 3.1.9. The beta, 3.2, has experimental code and no longer uses the cache tables. I haven’t yet decided whether to move ahead with this (and get rid of the cache tables) or not.

    Reinstalled. Ok, the keyword cache and _related caches are back. Keywords all ok, but the scores are all 0 zero. The install is ok, no errors on updating and showing the ‘consolation prize’ but no posts.
    The theme designers say turn off “Automatically display related posts?” but if I don’t it just inserts the “no post/consolation prize” text as a line at the bottom of the post.

    Is that a ‘score’ problem? I’ve tried almost every combination, setting is at 1 now.

    Thanks for your help.

    @freditor, you might want to try the latest beta, 3.2 beta 3. By default, this version goes back to the custom table-based caching method, though this can be changed with your wp-config.

    Thanks. I deactivated, deleted and did a manual install of the beta but it threw a ‘fatal error’ on activating
    Fatal error: Call to a member function is_enabled() on a non-object in blah blah \wp-content\plugins\yet-another-related-posts-plugin\includes.php on line 64

    Line 64 seems to be cache related.

    Did I miss something? Do I need to manually clear the DB cache?
    Fred
    (Happy New Year)

    Freditor, I noticed this myself and just pushed beta 4 which fixes this issue.

    Thanks, after on and off for days I’ve looked, but for the life of me I can’t see a beta 4 download anywhere. When you said you pushed it…?

    Got and installed that, thanks Mitcho. It’s building a healthy keyword cache and returning a few items in related cache but all with a score of zero and ID of zero and not displaying them anywhere, (I even tried the widget in the sidebar).

    I’ve poked at all the settings, levels, reset them, but until it enters a score I figure I’ll never see them on a page.

    Huh, interesting. I’m sorry but I’m about to push version 3.2, and I don’t think I’ll have this resolved for this release, then. Let me get back to you in a bit and ask you more questions.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Plugin: Yet Another Related Posts Plugin] Building the cache’ is closed to new replies.