WordPress.org

Support

Support » Plugins and Hacks » Yet Another Photoblog » [Plugin: Yet Another Photoblog] Error: File does not exists!

[Plugin: Yet Another Photoblog] Error: File does not exists!

  • There is currently a serious error with the plugin rendering it useless. If I write a new post then try saving it, I get a blank white screen with the following error:

    Error: File does not exists!

    If I hit refresh to see if my site has just crashed at the save moment, I get this error instead:

    Warning: unlink() [function.unlink]: No such file or directory in /home/++++/++++/ourcraft.co.uk/wp-content/plugins/yet-another-photoblog/lib/YapbImage.class.php on line 649

    Error: File does not exists!

    But the file does exist! I have downloaded a fresh install of the plugin, de-activated it, uploaded it, re-activated it, still the same problem.

    I even de-activated every other plugin except YAPB and tried saving again (to see if it was a conflicting plugin) still the same error. I finally de-activated every plugin, including YAPB and again tried to create a post. This time it worked. It also works if I activate every other plugin and keep YAPB de-activated.

    So what’s the problem as I have used this plugin in the past and it’s been fine?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hello?

    I posted this directly to the plugin authors site but for some reason he never approved my comment and just deleted it! What a great way to treat users who are reporting about serious errors with your plugin!

    I can see that I’m not the only person having the same problem, will there be a fix or has this now joined the pile of other obsolete plugins? I really hope not…

    Any response would be appreciated, thanks!

    I have the same problem

    I have the same problem too. I have tried a completely new installation with only the YAPB plug-in and the default theme, and I get the “file does not exist” error when creating a new post.

    I’m not sure about other versions but in WordPress 3.0.4, log into wp-admin and under ‘Settings’ down the left click on ‘Media’.
    (I think the same area is under Settings -> Miscellaneous in older versions of WordPress – could be wrong though)

    Under ‘Store uploads in this folder’ type in: wp-content/uploads
    Even though WordPress shows ‘Default is wp-content/upLoads’, YAPB doesn’t seem to acknowledge that!

    Fixed it for me anyway. Hope it helps

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: Yet Another Photoblog] Error: File does not exists!’ is closed to new replies.
Skip to toolbar