WordPress.org

Support

Support » Plugins and Hacks » Yelp It » [Plugin: Yelp It] Using the ID feature keeps returning the wrong business

[Plugin: Yelp It] Using the ID feature keeps returning the wrong business

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author coffeesnobdavis

    @coffeesnobdavis

    You have to specify the “business” method, it’s “search” by default. Also, there’s no space between yelp and profile.

    Try this:

    [yelpprofile method="business" id="childrens-hospital-and-research-center-oakland-oakland-2" align="left"]

    Plugin Author coffeesnobdavis

    @coffeesnobdavis

    I just checked in an update that will auto-detect which method you are using (depending on whether you set “id” or “term” and “location”). You should be able to update the plugin to version 0.3 by tomorrow if you don’t want to set the method parameter. It won’t break even if you do.

    I’ve been trying to add this plugin and on my site and all throughout your site http://coffeesnobdavis.com/yelp-it/ it reads “One or more parameters are invalid in request” where the yelp information should display.

    Did yelp change something? Can you give me an actual example of how this is suppose to read? [yelpprofile term=”search term” location=”city, zip, etc” limit=”5″ align=”right”]

    I’ve tried a number of times to adjust the parameters for it to work and I can’t get it.

    Thank You!

    Plugin Author coffeesnobdavis

    @coffeesnobdavis

    Yelp was undergoing maintenance earlier today so the API was down. Try again now, it works for me.

    I’m sorry I’m still not seeing anything. Just this error msg:

    “One or more parameters are invalid in request”

    It still says it on your page too:

    http://coffeesnobdavis.com/yelp-it/

    Is this exactly what the short code is to look like?

    [yelpprofile term=”search term” location=”city, zip, etc” limit=”5″ align=”right”]

    Thanks 🙂

    Plugin Author coffeesnobdavis

    @coffeesnobdavis

    Looks like Yelp broke something in their update. Try using id instead of term, looks like that’s still working. I’ll post when it’s fixed.

    [yelpprofile id="the-waterboy-sacramento" align="left"]

    Ok great thanks! 🙂

    Plugin Author coffeesnobdavis

    @coffeesnobdavis

    Checked in a fix, they require a sort value and I was just passing sort as blank if the user didn’t set it explicitly. version 0.3.1 … not sure when the wordpress.org will update it.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: Yelp It] Using the ID feature keeps returning the wrong business’ is closed to new replies.
Skip to toolbar