Support » Plugin: YAK for WordPress » [Plugin: YAK for WordPress] Teething Troubles with YAK

  • Dear Jason,

    First off, thanks for what appears to be a great plugin.

    I’m trying to use your plugin for my site here:

    But for some reason clicking the button does not seem to behave as expected. It just times out, trying to reach .

    I tried deactivating other plugins with no success.

    I’m using PHP 5.2 with FASTCGI plugin and mod_security. Dreamhost is my host and I’m using Suffusion theme.

    I’m using permalinks set to /%category%/%postname%

    Am I missing something obvious?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Dear Jason,

    A few questions about tweaking your plugin.

    I want to use YAK to build a list of services needed by the website visitor. Analagous to building a shopping list but quite a few text changes would be needed to give to copy a different feeling.

    I would like to do the following:

    1. Change the buy button text
    2. Adjust the widget to show all items in the cart.
    3. Edit the text within the widget and checkout page.

    Can you advise on best practice to make these changes?

    Further to my first post… switching off ssl AND ensuring “Redirect on buy” to checkout page fixed the problem.

    Yak General > Use SSL checkout > No Check mark
    Yak General > “Redirect on buy” > Empty <–Breaks again

    But any recommendations on how to use SSL aand no redirect?

    Plugin Author nolongeractive


    If I go to your site with https, it times out — that’s nothing to do with yak. i.e. for me right now if I go to:

    it works fine. However:

    times out.

    I think you need to resolve that issue first.

    In answer to your other questions:

    1) buy button text can be changed using a translation file. basically a translation for english which modifies the specific text you want to change

    2) that would require changing the PHP file: yak-view-order-widget.php

    3) text in the widget and checkout can be changed in the same way as (1)

    Thanks Jason. Very helpful. I completely overlooked the fact I need a unique ip address to do https. Woops!

    So for now I turn off the SSL feature.

    Then the problem is “Error 404 – Not Found” when I click the buy button.

    If I change

    Yak General > “Redirect on buy” > Empty
    Yak General > “Redirect on buy” > Checkout.

    It works again – but I want the item just added to the cart, not take one to a seperate cart page.

    Any suggestion?

    Plugin Author nolongeractive


    index.php is the main entry point for WP, so for that not to work, there must be some kind of redirect causing a problem.

    Thanks for the pointers…

    So this is what I tried.

    1. Disabling all plugins.
    2. Checking my .htaccess. It’s standard WordPresss .htaccess.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    # END WordPress

    3. Changing permalinks to default WordPress permalinks option. Same.
    4. New WordPress install, no plugins installed, install Yak. Same problem. See here:

    So all I have installed is YAK and it still don’t work!

    5. Same host… maybe it’s a host thing… Dreamhost has a option to remove www. from domains which use.. perhaps this is causing the problem. Turned it off.. Also turned off “mod-security” whilst i’m here incase that was it. Same results.

    I really love the elegance of the concept of using posts/pages as products in your solution Jason.

    But this feels almost like a first date with a beautiful girl, it’s gone well, you drop her off at her door, she’s whispering nice things in your ear, giving you a peck on the cheek then saying good night.

    Just frustrating.

    So I’m struggling here… how would you start investigating such a redirect problem Jason?

    I don’t giveup easily…

    So I noticed part of the problem.

    The buttons on the product page ([yak_product_page]) don’t work, and that’s where I’d been checking mostly.

    But the buttons on the actual page do work.

    Only problem once I’ve added it to my cart, click on the proceed to checkout link in my sidebar, and my cart empties itself and proceeds to tell me to choose something to buy.


    Plugin Author nolongeractive


    I can’t explain it other than a hosting issue then. I tried your other link ( and that appears to be vaguely working. There’s a problem with the “proceed to checkout” link (looks like it hasn’t been configured to point at the right page), but the add button works (although you still end up with a 404 error), and if you go to the checkout link directly, the product has been added to the cart.

    I haven’t seen this scale of problem before, so not quite sure what to suggest.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: YAK for WordPress] Teething Troubles with YAK’ is closed to new replies.