Support » Plugin: YAK for WordPress » [Plugin: YAK for WordPress] Compatible with WordPress 3.4.1?

  • I just updated wordpress for my site and the [yak_checkout] function doesn’t work anymore … i am getting the following error message:

    Fatal error: main() [<a href='function.main'>function.main</a>]: The script tried to execute a method or access a property of an incomplete object. Please ensure that the class definition &quot;YakItem&quot; of the object you are trying to operate on was loaded _before_ unserialize() gets called or provide a __autoload() function to load the class definition in /yak-for-wordpress/yak-view-cart.php on line 81

    I didn’t change anything except my version of wordpress…

    thanks

    http://wordpress.org/extend/plugins/yak-for-wordpress/

Viewing 1 replies (of 1 total)
  • Plugin Author nolongeractive

    (@jrbriggs)

    It’s unlikely to be just the WordPress upgrade. That error is caused by another plugin starting sessions outside of the WordPress init action. Basically they’re not doing it the right way.

    However, I’m not sure why this is only appearing after a WP upgrade.

    Best thing to do is disable all other plugins check that YAK works, then re-enable one by one until it breaks.

Viewing 1 replies (of 1 total)
  • The topic ‘[Plugin: YAK for WordPress] Compatible with WordPress 3.4.1?’ is closed to new replies.