WordPress.org

Support

Support » Plugins and Hacks » YAK for WordPress » [Resolved] [Plugin: YAK for WordPress] 404 error on Checkout page

[Resolved] [Plugin: YAK for WordPress] 404 error on Checkout page

  • I have upgraded WP to 3.0 and upgraded to current yak plugin (2.2.1), uninstalled and reinstalled yak, and followed all setup instructions (both brief and in purchased doc) to the letter, I swear, but I cannot get the checkout page working. I have the redirect setting pointing to Checkout page. Both the Buy now button and Checkout listing in Pages widget give Error 404-Not Found. Please advise!

    http://wordpress.org/extend/plugins/yak-for-wordpress/

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author nolongeractive

    @jrbriggs

    I think the first thing to try is to disable all other plugins to see if one of them is causing an incompatibility since the upgrade. I know when I upgraded my own site, I automatically upgraded a number of other plugins at the same time.

    Oh, shoot–I forgot to write above that I DID deactivate EVERY SINGLE OTHER plugin before writing. It wasn’t working (same exact problem) on the old versions of WP and YAK with or without other plugins, and it’s not working on the new versions of WP and YAK without other plugins. (I haven’t started reactivating the plugins since doing the upgrade yesterday.)

    Have you seen problems caused by themes, perhaps? I’m using a version of “pixel”. My site is http://globalpragmatica.com, in case it helps.

    Thanks! I like how you’ve designed the product overall–looking forward to getting it working!

    Well, how about that–I solved my own problem. I was using a custom template instead of default template. Default template works beautifully. Argh. Stupid me. Thanks so much!

    I wrote too soon. Now the “Confirm order” button is dead, whether I’ve chosen payment to test SPECIAL: Google Checkout (Live) (configured as described in ch2) or to test a Direct Deposit PAGE configured as described in chapter 1. I’m pretty sure I haven’t missed any of the documented steps (and yes, I’ve got “default template” for the Dir Dep page) but the Confirm Order button is dead no matter what I do. Not getting any error messages or hints…

    Plugin Author nolongeractive

    @jrbriggs

    Dead? As in 404 again, or when you click nothing happens. If the latter, try viewing firefox’s error console to see if something shows up there.

    When I click, nothing happens–nothing at all. The Error console is completely empty. Very puzzling.

    Here’s a $1 bogus product you could try buying by Direct Deposit if you’d like to see its deadness for yourself: https://globalpragmatica.com/?cat=53

    Plugin Author nolongeractive

    @jrbriggs

    The confirm order butto worked when I tried it…. Well sort of. It blew up with a session error. What other plugins do you have installed? That particular error is generally caused by a plugin starting a session in a non-WP-standard way, in my experience.

    Over the weekend I reactivated some of my plugins. I’m getting this error:

    Fatal error: main() [function.main]: The script tried to execute a method or access a property of an incomplete object. Please ensure that the class definition "YakItem" of the object you are trying to operate on was loaded _before_ unserialize() gets called or provide a __autoload() function to load the class definition in /home/content/e/r/i/erinvang/html/wp-content/plugins/yak-for-wordpress/yak-view-confirm.php on line 96

    when the following plug-ins (all current versions) are activated:

  • Feedburner Email Widget & FeedBurner FeedSmith
    Google XML Sitemaps
    Mollom
    SEO Ultimate
    statistX
    Twitter Blog
    Wordpress Download Monitor
    WP Email Capture
    WPtouch iPhone Theme
    YAK for WordPress
  • When I deactivate ALL of these plugins, the button is “dead” (does nothing and gives no errors). I’m leaving ALL plugins except YAK deactivated tonight so you can see this behavior.

The only things I’m seeing in my Firefox Error Console are:

globalpragmatica.com : potentially vulnerable to CVE-2009-3555

Unknown property ‘align’, ‘border-top-*’, etc. (declaration dropped) in the yak ui.css file

Eureka! The problem is in the Terms & Conditions option–removing it fixed the problem. More detail tomorrow–don’t want you to waste any time on it in the meantime.

My finding is that using the YAK Settings/Basic/Terms & Conditions text box is the problem. I thought initially that I was trying to be too tricky with it, as my text had a hyperlink in it, but retesting today even with just a simple string (“this is a bogus message”) broke the Confirm Order button again (made it nonresponsive with no errors to the console). When I leave the option blank, all is well.

Any advice? Am I correct in thinking this is a YAK bug? Thanks so much for your support. I’m excited to be getting my store working finally.

Plugin Author nolongeractive

@jrbriggs

Whoops. Much as I’d like to say it’s not a bug… it is. Introduced in the latest version, it appears.

Thanks for the report. It’ll be fixed in the next release.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Resolved] [Plugin: YAK for WordPress] 404 error on Checkout page’ is closed to new replies.
Skip to toolbar