Support » Plugin: Yahoo Weather » [Plugin: Yahoo Weather] Host Server will not allow 777 permissions

  • fedude

    (@fedude)


    Here is a message from the largest hosting provider in the world:

    My script needs to use 777 permissions

    For scripts that require ‘0777’ directory permissions, we do not allow those permission settings on files or folders.

    Please try to set the directory to 0755 instead (drwxr-xr-x). This will enable read-execute, but not write access for group and world.

    If the script absolutely requires 0777 permissions, please email support@hostgator.com for further solutions.

    Why can’t I use 777 permissions?

    777 permissions on folders and files is a website security risk, so we do not allow you to have them.

    Most hosting companies now use suPHP servers, thus 755 will allow PHP to read, write and execute scripts just like 777 does. Because of this, most scripts work when you use 755.

    http://wordpress.org/extend/plugins/yahoo-weather/

  • The topic ‘[Plugin: Yahoo Weather] Host Server will not allow 777 permissions’ is closed to new replies.