Support » Plugins and Hacks » [Plugin: xLanguage] Problem with static frontpage

[Plugin: xLanguage] Problem with static frontpage

Viewing 9 replies - 1 through 9 (of 9 total)
  • Yes.. I have the same problem.. πŸ™



    <?php echo $xlanguage->filter_text(‘ΠŸΠΎΡ€Ρ‚Ρ„ΠΎΠ»ΠΈΠΎ|Portfolio’); ?>

    I had same problem.
    It was .htaccess file having problem.
    I saved in mode of UTF8. must be saved ASKII mode.
    i changed it,add permission 666 and set on the config page of wordpress about “permanent link”.
    i set it “numeber” link name.(i do not know how to say cos i am using japanese version)
    then front page came with like this page’s URL

    I mean, saved UTF8 that is very basicaly my falt, but there is the problem around “.htaccess” flie or “permission” or “Apache configlation(AllowOverride)”, could be.

    *wordpress can access to .htaccess file and overwrite , when you set permanent link.but if you didint add permission 666, wordpress say “you must change contents of .htaccess by your self”so, if you can change it, you should do before you do anything.

    similar / same problem.
    xlanguage is adding the following suffix to language link to home page and therefore the link does not work and gets rerouted to the “no posts found page” (I am not using posts, only pages here)

    chinichiro’s answer looks a little complicated and unclear.
    Can’t seem to find a solution and am going have to try a different plugin which is not what I want to do, unless ….?

    Yey – OK, got it resolved by changing Permalink setting in WP Settings from Default (I used “Day & Name”)

    Mr. neptunian
    sorry, my english is not good, just trying to get smart but it is quite difficult and all.

    yeah, you got success, that s cool.
    just i leave some information for come to here with having same problem guys.

    just i mean, when you can not fix fornt page while useing xlanguage plugin, Doubt belows

    # if you do not need staticURL, just set default of permalink
    # check and dig anything around .htaccess
    # check permission of . htaccess to 666
    # fixed your pages? from settings
    # check again permalink(i am using “number”)
    # your server allows “AllowOverride”?


    I having a little bit of a different problem. I have a static page. On this page I am using some javascript to create a series of tabs. Whenγ€€οΌ©γ€€ο½ƒο½Œο½‰ο½ƒο½‹γ€€ο½”ο½γ€€ο½ƒο½ˆο½ο½Žο½‡ο½…γ€€ο½”ο½ˆο½…γ€€ο½Œο½ο½Žο½‡ο½ο½•ο½‡ο½…ο½“γ€€ο½‰ο½”γ€€ο½“ο½…ο½…ο½ο½“γ€€ο½”ο½γ€€ο½‚ο½…γ€€ο½‚ο½’ο½…ο½ο½‹ο½‰ο½Žο½‡γ€€ο½”ο½ˆο½…γ€€ο½“ο½ƒο½’ο½‰ο½ο½”οΌŽI am using the same script on the single.php pages I have and there is no problem there. I know it has something to do with the way I have linked the script on the static page but I can’t seem to figure it out. γ€€οΌ©ο½†γ€€ο½ο½Žο½™ο½ο½Žο½…γ€€ο½ˆο½ο½“γ€€ο½ο½Žο½™γ€€ο½”ο½‰ο½ο½…γ€€ο½”ο½γ€€ο½ˆο½…ο½Œο½γ€€ο½ο½…γ€€ο½ο½•ο½”γ€€ο½‰ο½”γ€€ο½—ο½ο½•ο½Œο½„γ€€ο½‚ο½…γ€€ο½‡ο½’ο½…ο½ο½”ο½Œο½™γ€€ο½ο½ο½ο½’ο½…ο½ƒο½‰ο½ο½”ο½…ο½„οΌŽγ€€οΌ΄ο½ˆο½…γ€€ο½ƒο½•ο½’ο½’ο½…ο½Žο½”γ€€ο½ο½ο½‡ο½…γ€€ο½‰ο½“γ€€ο½—ο½—ο½—οΌŽο½‚ο½…ο½”ο½οΌŽο½ƒο½‰ο½…ο½„ο½•ο½ƒο½ο½”ο½‰ο½ο½Žο½ο½ο½’ο½”ο½ο½ŒοΌŽο½ο½’ο½‡οΌŽγ€€οΌ΄ο½ˆο½…ο½’ο½…γ€€ο½‰ο½“γ€€ο½γ€€ο½ο½ο½“ο½“ο½—ο½ο½’ο½„γ€€ο½ο½Žο½„γ€€ο½•ο½“ο½…ο½’ο½Žο½ο½ο½…γ€€ο½“ο½…ο½”γ€€ο½“ο½‰ο½Žο½ƒο½…γ€€ο½ο½™γ€€ο½ο½’ο½‡ο½ο½Žο½‰ο½šο½ο½”ο½‰ο½ο½Žγ€€ο½’ο½…ο½ο½Œο½Œο½™γ€€ο½„ο½ο½…ο½“οΌ‡ο½”γ€€ο½—ο½ο½Žο½”γ€€ο½ο½Žο½™ο½ο½Žο½…γ€€ο½”ο½γ€€ο½“ο½…ο½…γ€€ο½”ο½ˆο½…γ€€ο½“ο½‰ο½”ο½…γ€€ο½™ο½…ο½”οΌŽγ€€οΌ¨ο½ο½—ο½…ο½–ο½…ο½’οΌŒγ€€ο½“ο½‰ο½Žο½ƒο½…γ€€οΌ© am stumped on this one I need to open it up to community for a little while.

    οΌ΄ο½ˆο½…γ€€ο½•ο½“ο½…ο½’γ€€ο½Žο½ο½ο½…γ€€ο½‰ο½“οΌš ADMIN the password is: CHINAED1212

    both are in all capital letters. I will be changing this in a few days. Thanks in advance for anyone who can help.



    If anyone else is having the problem I mentioned above I figured it out. It looks like if you want run any scripting on your static page with xlanguage installed you cannot use site relative links you must use the full path to the directory. Thanks.


    Hi there,
    same problem here. It does not work with the default permalinks, but it does with any of the other ones. Trouble is that no matter what other permalink choice I tick the URL do not really correspond to the page title.
    Any ideas on how to correct that?

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: xLanguage] Problem with static frontpage’ is closed to new replies.