WordPress.org

Support

Support » Plugins and Hacks » [Plugin: XCloner – Backup and Restore] Error:failed to open stream

[Plugin: XCloner – Backup and Restore] Error:failed to open stream

  • After following the steps at the T, I got the following error message when I try to open the website in the subfolder (shared hosting account):
    “Warning: require(/home/<user-name>/public_html/<restored-site>.com/wp-includes/classes.php) [function.require]: failed to open stream: No such file or directory in /home/<user-name>/public_html/<restored-site>.com/wp-settings.php on line 267”

    Notes aside: I think the coder too much Joomla oriented, instead WordPress oriented. As a result of that, the whole user manual and wiki has ONLY Joomla screenshots. You have to translate those instructions and images to how that could be in the case of WordPress. I would recommend to the coder to develop Support Documentation to WordPress users (screenshots and instructions), because those are pretty different from the viewpoint of a Joomla user.

    Thanks,
    wpfanatic

    http://wordpress.org/extend/plugins/xcloner-backup-and-restore/

Viewing 1 replies (of 1 total)
  • Plugin Author xcloner

    @xcloner

    The error you have there usually indicates the files were not restored properly, have you checked with a ftp client if the missing files are present in the restore location?(ex: /home/<user-name>/public_html/<restored-site>.com/wp-includes/classes.php)

    You can several options to make this work:
    1. if you use the ftp upload mode, have you checked that the ftp upload path was correct? should point to the same folder as indicated in the “Install dir:” restore path
    2. have you tried the restore by using the “Install files directly” option checked?
    3. have you tried extracting the backup archive manually, and then restoring with the “Skip files restore” option checked?
    4. have you checked if the backup archive has the same size as on the original host, are you able to open it?

    Any details you can share here about the paths and restore options you used when restoring, would help us in figuring the issue you have! And as always, make sure php.ini safe_mode is disabled.

    Cheers, Ovidiu

    As always,

Viewing 1 replies (of 1 total)
  • The topic ‘[Plugin: XCloner – Backup and Restore] Error:failed to open stream’ is closed to new replies.