WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: XCloner – Backup and Restore] Broken

[Resolved] [Plugin: XCloner – Backup and Restore] Broken

  • The option menu in Plugins > XCloner just shows… my homepage in frame, lol. I’ve touched nothing yet, only uploaded the xcloner folder to my WP plugins directory and activated it. Just won’t work!

Viewing 15 replies - 1 through 15 (of 24 total)
  • Plugin Author xcloner
    Member

    @xcloner

    XCloner can also be accessed directly using the link to the plugin folder, like

    http://[mysite.com]/wp-content/plugins/xcloner-backup-and-restore

    If you still get a blank page there, i would advise enabling php errors on your server to see what the actual error is, what php version are you running?

    Ovidiu

    PHP Version : 5.2.17

    And yes you are right. Using the URL you gave me, I can access the XCloner Manager Authentication Area immediately. Thanks for your so quick support. And sorry for being a noob, lol

    Note: with one more vote, the compatibility check of your WP.org plugin page is now green 😉

    Sorry to be bothering but I need more help. Here is a screenshot of the page I get in the User Authentication tab of the Settings menu.

    I can’t find nor a save button nor any way to save my changes. Do you have any idea of where I should look for it? Do I have to “Edit config file: cloner.config.php” manually?

    Plugin Author xcloner
    Member

    @xcloner

    That is pretty weird, can you check and see if you get any javascript errors, usually you should see the Save button in the top right, are you able to see the toolbar buttons in the View Backups area for instance?

    If you are able to share that page url, please send me an email here http://www.xcloner.com/contact/ and i will take a look to see what the issue is, please include also the XCloner admin details

    Regarding the frame error you got, could it be caused by a local firewall/ads blocker from your computer?

    Regards, Ovidiu

    The problem can’t come from firewall but could come from my NoScript and AdBlock Plus extensions for Firefox. Even if I had already added some rules to allow javascript from xcloner.com, now I’ve completely disabled the 2 extensions. But the problem remains the same.
    After more researches, I can see in Firebug that both Save and Cancel buttons are located in div id="toolbar" but this toolbar is set to style="display:none" (screenshot). I’ve tried with Firefox, Chrome and even IE8. I can see the 2 Logout and Cancel blue buttons on top-right in XCloner Main Menu from any browser. But there’s no more button when I click on Settings. Really strange. I’ve searched for a problem with my CSS styles, but the display property is set in the div element itself, not in any CSS file.

    And yes, I can also see the 5 buttons of the top toolbar in View Backups area. Even more strange.

    There’s no post in my blog because it’s a kind of template, a site configuration that I will copy to multiple blogs, so I’ll just have to change the theme for each one. I’ve sent you more details through your contact form.

    Ok, the frame problem is simple to solve. For my blog’s security I’ve renamed the /wp-content/ folder to /files/ (using the WordPress wp-config.php file). So I’ve edited xcloner.php to change the plugins path.

    Maybe the future releases of your WordPress plugin could use the WP plugins_url() function to avoid this for other users but I don’t know if it is technically possible.

    Anyway it seems to be not so important as it doesn’t fix the buttons problem. But at least now I can open XCloner from the WP Admin area.

    Also found the wp-content/ directory in cloner.config.php. Replaced too and still doesn’t make the top right buttons appear in Settings. the only change is Temporary Path Check in main page shows Invalid directory (/home/fenyx/domains/anydomain.com/public_html/administrator/backups) now. Why is it not finding the right plugins directory anymore? I don’t know. Above all I can’t try to fix anything without the Save button, as you already know.

    I hope all your users aren’t causing you as much troubles as me, lol

    The HTTP Headers monitored when clicking the Settings button in Main Menu: [link]

    Not sure it could help by any way.

    Plugin Author xcloner
    Member

    @xcloner

    From what i have been able to check, the server seems to stop the script when it asks if the exec function is enabled, around line 2053->2056

    if(function_exists(“exec”)){

    $out = @exec(“ls -al”);
    }

    inside the wp-content/plugins/xcloner-backup-and-restore/admin.cloner.html.php file, check the XCloner Config, Info tab, you will see that page is incomplete

    I would advise checking with your hosting support on this as the issue is generated by their server config, or simply remove that code, it should help.

    Regards, Ovidiu

    I’ve tried to remove the part you’ve shown me so now it looks like this:

    <?php
    
    			$out = "";
    
    		        $val = ($out != "")? "ENABLED":"<font color='red'>DISABLED</font>";
    		        echo HTML_cloner::get_color($val, 'DISABLED');
    		        ?>

    But it still doesn’t work. Should I remove this entirely too?

    I don’t understand why their server would add a display:none style to the DIV but I’ll follow your advice and will discuss it with my hosting support team.

    Thanks a lot for your efforts to help me. I will let you know the result of the discussion with support…

    By the way, Php open_basedir returns a red text:
    “/home/myname/:/tmp:/var/tmp:/usr/local/lib/php/”
    I don’t know why it’s in red text but this path seems complicate too me. Couldn’t it be related?

    Plugin Author xcloner
    Member

    @xcloner

    The open_basedir is not related to this matter, we mark that with red in case users need to track down permission issues.

    Regarding the display:none, that code is being enabled only when the page is fully loaded, so when the config page will display properly, that code should work

    Ovidiu

    Aaah ok. Thanks for your patience and your explanations 😀

    Confirmation by WeServIT.nl support team:

    Hi,

    The exec command is disabled for security reasons. If we enable this, clients would be able to execute Linux commands on our servers.

    So my only way seems to be a Linux VPS. More expensive but I will seriously think about it. I just think that my lack of skills could be a big problem. Still hesitating.

    I’m really thankful for all your help and for the time you’ve been working on solving my problem. And for sure I will install XCloner as soon as it will be technically possible to me.

    Plugin Author xcloner
    Member

    @xcloner

    XCloner does not require the exec function to be enabled, it can work without it also, just that the code should not break when it asks for that function existence, so I think your hosting support still need to fix this!

    Send them the code i sent you earlier so they can test it, the script should finish execution under normal conditions with or without exec function enabled!

    Regards, Ovidiu

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘[Resolved] [Plugin: XCloner – Backup and Restore] Broken’ is closed to new replies.