Support » Plugin: Widget Content Blocks » [Plugin: WYSIWYG Widgets] HTML and Visual Tabs don't work and none of the WYSIWIG buttons show

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Danny van Kooten

    (@dvankooten)

    Hi Gruvii,

    Thanks for the report.

    From the screenshots it looks like you’re using WP 3.3? WYSIWYG Widgets is not yet compatible with WP 3.3, I’m currently looking into this.

    Kind regards, Danny

    Danny: The new editor is muuuuch easier to use, however keeping some level of backwards compatibility is going to be a pain for a while. Here’s a good article on using the new one:

    http://soderlind.no/archives/2011/09/25/front-end-editor-in-wordpress-3-3/

    Hey Danny, love the plugin! Hoping for an update soon as with WP 3.3 it is not only not showing any buttons or tabs, but also locking up all the widgets so they won’t open.

    When WYSIWYG Widgets will be compatible with WP 3.3 please ?
    Thanks !

    Danny, it seems like you are always chasing the WordPress team as you maintain the single most valuable plugin I use for my clients. I really hope you are able to figure it out for 3.3, I updated a couple of sites before I noticed the plugin was incompatible.

    Please please please let us know as soon as your fantastic plugin is compatible with 3.3.

    Thanks!

    I’m not using that widget, but have you tried the ‘Use Google Libraries’ plugin? it worked to bring back the editor buttons etc on the admin side. it might work.

    Plugin Author Danny van Kooten

    (@dvankooten)

    Just updated WYSIWYG Widgets to version 1.2, which should be fully compatible with WP 3.3. Let me know if you still experience any issues.

    http://wordpress.org/extend/plugins/wysiwyg-widgets/

    Note that the widget doesn’t work with WP 3.3.1. Clicking on the writing area does nothing and the widget refuses to respond to bring up the WYSIWYG editor. I certainly hope this issue can be solved, because this is a feature sorely needed for WP. Thanks.

    I now noticed that after installing the tiny mce advanced text editor that the WYSIWYG Widgets finally showed the editor buttons, but nothing in the text box worked and no text could be entered. Please let me know if you have a work around. Thanks!

    Okay, after some more playing around I got it to work, but with some quirks. After installing the tiny mce advanced text editor the WYSIWYG editor buttons showed up but didn’t work. I then got the idea to allow pop-ups in Firefox, which then resulted in the widget working. However, there still are some potential bugs. The word wrap doesn’t work in the window size–it allows words to spill over too far to the right and out of sight. Also, the text window doesn’t seem to open up the way you state, but it just opens similar to the basic text editor widget that comes with WP. Hope this helps to get everything working.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Plugin: WYSIWYG Widgets] HTML and Visual Tabs don't work and none of the WYSIWIG buttons show’ is closed to new replies.