WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Wysija Newsletters] Request error not JSON

[Resolved] [Plugin: Wysija Newsletters] Request error not JSON

  • I try to drop in the WordPress post widget to create the newsletter and I get a Request error not JSON error. Then I click ok and try to find the article throught the search function, then I get the same error again

    Request error not JSON:
    <b>Warning</b>: Cannot modify header information – headers already sent by (output started at /home/atv/planetmonkey.co.uk/wp-content/plugins/wysija-newsletters/controllers/ajax/campaigns.php:1) in <b>/home/atv/planetmonkey.co.uk/wp-content/plugins/wysija-newsletters/core/base.php</b> on line <b>2</b>
    {“result”:{“posts”:[],”msg”:”There are no posts corresponding to that search.”,”result”:false},”msgs”:[]}

    What I do is I delete all content and try to import a wordpress post. It doesn’t work. On the right side of the page, there is always a message displayed “Saving newsletter…” Themes are not working they are not selectable. What a pity, I quite liked how it all worked till I tried to compose a newsletter!

    http://wordpress.org/extend/plugins/wysija-newsletters/

Viewing 15 replies - 16 through 30 (of 35 total)
  • Hi Ben,
    Fixed thanks but see below.

    I tried to create a new user with the same email as the admin email and of course it told me it already existed….so I added that admin subscriber to the list WordPress Synched and still generated the send error.

    The way it works was your last suggestion. Remove the admin email address from WordPress Synched list which I added earlier. Go to Users admin account, edit profile and Update, admin then re-appears in WordPress Synched list and error is fixed.

    Once again thanks for your help.

    Alan

    Ok Great 🙂

    I take good note of that we will improve that in one of the next version. It’s an annoying bug that should not be.

    Thanks for the feedback 🙂

    Ben

    Hello,

    i keep getting the following when i try to send test email:
    Request error not JSON:
    Notice: Trying to get property of non-object in E:\inetpub\integralresolutions.org\wp-content\plugins\wysija-newsletters\helpers\toolbox.php on line 2
    {“result”:{“result”:false},”msgs”:{“error”:[“An error occured. <а href=”;”>Show more details.<\/а>”],”xdetailed-errors”:[“Subscriber not found : <b><i><\/i><\/b>”,”Subscriber not found : <b><i><\/i><\/b>”]}}

    I tried all of the above mentioned solutions but no luck.
    Also when i tried to make a new newsletter and send, i got the following in a new blank page:
    Security failure during request.

    Any ideas what im doing wrong?

    Cheers.

    Hi Kakov,

    It doesn’t look like you’re doing anything wrong! It seems to me that we still have a couple of bugs on our applications.

    It looks like the tables were not created, yesterday I have corrected a bug regarding the tables creation requests. I just have committed it on svn few minutes ago.

    Check that all the tables from wysija are created:
    wysija_user_list
    wysija_user
    wysija_list
    wysija_campaign
    wysija_campaign_list
    wysija_email
    wysija_user_field
    wysija_queue
    wysija_user_history
    wysija_email_user_stat
    wysija_url
    wysija_email_user_url
    wysija_url_mail

    If they are not then :
    delete your version of wysija
    reinstall wysija with the latest version on repository
    run the following url to uninstall completely wysija:
    http://yourwebsite.com/wp-admin/admin.php?page=wysija_campaigns&wysija-uninstall=1
    and then run the following url to reinstall wysija:
    http://yourwebsite.com/wp-admin/admin.php?page=wysija_campaigns

    Now tell me how did it go.
    Are they still some missing tables?

    Cheers,

    Ben

    I deleted and reinstalled, deleted all subscribers etc remake and no luck.
    I`m guessing there is something to do with the host since its windows hosting or something with the permissions in the data base since i cant save a newsletter.
    Ill have to use another plug in since the hosting provider is kinda moronic and i dont have the time and strength to argue.

    Looking forward to the next project so i can use this awesome plugin.

    P.S.
    I installed it on my own server, where i actually have access to the data base and it worked just fine.

    Cheers.

    Hey Kakoz,
    That’s too bad!
    Hopefully we will correct that for this kind of host at some point.

    Thanks for the compliment. 🙂

    Ben

    Hi I am having problems with subscription.
    When user enters email and then clicks subscribe .
    This error comes up .

    textStatus:error
    errorThrown:Not Found

    what can I do about it ?

    thanks

    Arm

    Hi dno555,

    Could you replace the file wysija-newsletters/core/base.php with the one zipped here: http://support.wysija.com/files/2012/02/base2.zip
    this should do the trick.

    Try it ou and let me know.

    Cheers,

    Ben

    HI ben ,
    It worked .
    Thank you very much

    Hello,

    I use Gigawatt theme and if I put one picture in one article, I have one error when I want choose one article in wysija. I cant see the list of articles.

    error : Request error not JSON

    Sorry for my english. Thanks for your support.

    Hi Landiiv,

    Your problem seems different than the other users.
    Could you come to http://support.wysija.com and post a ticket so that we can take it from there.

    CHeers,

    Ben

    Ok Ben I do that

    Thank you

    Hi Ben

    I installed the plugin with admin1@anywhere.com set as admin email. and I wanted to use smpt server to send emails using the admin2@mydomainname.com set as admin email. when I tested the email I received the same error stated above:

    Request error not JSON:
    <b>Notice</b>: Trying to get property of non-object in <b>/home/datetec/public_html/wp-content/plugins/wysija-newsletters/helpers/toolbox.php</b> on line <b>2</b>

    <b>Warning</b>: Cannot modify header information – headers already sent by (output started at /home/datetec/public_html/wp-content/plugins/wysija-newsletters/helpers/toolbox.php:2) in <b>/home/datetec/public_html/wp-content/plugins/wysija-newsletters/core/base.php</b> on line <b>165</b>
    {“result”:{“result”:false},”msgs”:{“error”:[“An error occured. Show more details.<\/a>”],”xdetailed-errors”:[“Subscriber not found : <b><i><\/i><\/b>”,”Subscriber not found : <b><i><\/i><\/b>”]}}

    I think my problem was exactly similar to DateTec’s problem and I believe I could have solved it if I saw it earlier. What I did instead, I went into my database and deleted all Wysija related tables thus when I tried to re install it the problem was still there. then, I tried to run the uninstall script to re install it as you suggested to kakoz, unfortunately I can’t run the uninstall script because I am always asked to log in and when I log in only my dashboard’s home page appears. any idea of what I should do? any help would be really appreciated. thanks

    Hi tmayombo,

    Based on the errors you’re getting I’m quite confident you’re not using the latest version of wysija 1.1.3.
    Please update and try again this should fix that and a lot of other bugs 🙂

    In the new version of wysija we also have a reinstall button in Settings > Advanced .

    Try it out and let me know.

    Cheers,
    Ben

    p.s.:Try to always keep your software updated. It will save you time for sure !

    Hi Ben thanks for your quick reply. but I am using 1.1.3 and my wordpress version is 3.3.1 I still stuck. any suggestion?

Viewing 15 replies - 16 through 30 (of 35 total)
  • The topic ‘[Resolved] [Plugin: Wysija Newsletters] Request error not JSON’ is closed to new replies.