WordPress.org

Support

Support » Plugins and Hacks » MailPoet Newsletters » [Resolved] [Plugin: Wysija Newsletters] Request error not JSON

[Resolved] [Plugin: Wysija Newsletters] Request error not JSON

  • I try to drop in the WordPress post widget to create the newsletter and I get a Request error not JSON error. Then I click ok and try to find the article throught the search function, then I get the same error again

    Request error not JSON:
    <b>Warning</b>: Cannot modify header information – headers already sent by (output started at /home/atv/planetmonkey.co.uk/wp-content/plugins/wysija-newsletters/controllers/ajax/campaigns.php:1) in <b>/home/atv/planetmonkey.co.uk/wp-content/plugins/wysija-newsletters/core/base.php</b> on line <b>2</b>
    {“result”:{“posts”:[],”msg”:”There are no posts corresponding to that search.”,”result”:false},”msgs”:[]}

    What I do is I delete all content and try to import a wordpress post. It doesn’t work. On the right side of the page, there is always a message displayed “Saving newsletter…” Themes are not working they are not selectable. What a pity, I quite liked how it all worked till I tried to compose a newsletter!

    http://wordpress.org/extend/plugins/wysija-newsletters/

Viewing 15 replies - 1 through 15 (of 35 total)
  • Hi Quantum_leap,

    In the latest release we launched yesterday, a naughty invisible character inserted himself in the beginning of /controllers/ajax/campaigns.php causing all those crashes on your end, sorry about that.

    To fix that, replace the file /controllers/ajax/campaigns.php with the one zipped in here:

    http://support.wysija.com/files/2011/12/controllers-ajax-campaigns.zip

    Let me know if you’re still having any issues.

    Ben

    Hello
    When visitors wanted to suscribe, i have the same error
    Request error not JSON

    But after closing the window, a “Loading..” message is running without stopping.
    Nobody is receiving the confirmation link.

    Can you help me ?
    I’m using the latest update of WordPress.
    I try the tip you’re describing (change the campaign file) but nothing works.

    Thanks a lot.

    PS : if you want to see it in action, it’s on my website
    http://www.stellacuisine.com/

    Hi Stella,
    Indeed this bug is slightly different than the one described above.
    Can you try to install the latest package with the latest modifications we did in the last two weeks.
    This will not work for sure but this is worth a try.

    http://support.wysija.com/files/2012/01/wysija-newsletters1.zip

    If it still doesn’t work please contact us through our support system, we may need access to your site for further correction.

    http://support.wysija.com

    Cheers,

    Ben

    Hello
    Thanks for answering so fast.
    I have change the files on my FTP and the problem still the same.

    Where can I find the support system ?
    Thanks.

    Double. I’m Sorry.

    Hi Stella,
    The support is at this address:

    http://support.wysija.com

    Ben

    Stella came on our support website, and we finally solved her problem.
    The problem was linked to her site’s configuration.

    In /wp-admin/options-general.php her WordPress address (URL) address was :
    http://stellacuisine.com/
    While her Site address (URL) address was :
    http://www.stellacuisine.com/

    Making the ajax call for registration from http://www.stellacuisine.com towards http://stellacuisine.com/wp-admin/admin-ajax.php is impossible as cross domains ajax call are impossible.

    The solution to that problem is to activate the little fix plugin available over here:
    http://support.wysija.com/files/2012/01/wysija-allow-subdomain-cross-ajax.zip
    Which make the cross subdomain ajax call possible.

    That’s it folks πŸ™‚

    One more time thank you for your ability to react and the excellent quality of support website.

    Hello, i’m sorry i have a new problem with IE users…

    Request Error JSON : undefined

    And nothing happens (just Loading) but users can’t suscribe…
    Can you help me one more time please ?

    thanks

    Stella,
    On which version of internet explorer does this error happens?

    Thanks,

    Ben

    Well actually I tried with the latest version of IE and it doesn’t work :/
    By the way in firefox I see this error :

    i is not a function
    [Stopper sur une erreur] 	
    
    ..."){var a=document.createElement("img");a.setAttribute("id","shr_oven");var b=f+"...

    http://dtym7iokkjlif.cloudfront.net/dough/1.0/recipe.js

    This could break everything in IE for instance.
    I’m not saying that this is the reason but it could be.
    Could you deactivate the plugin which uses this script? THis might just solve it.

    I tried on other server the registration form on IE and it works fine.

    Let me know,

    Ben

    I have destactivate the Shareaholic plugin but it still doestn’t work with IE (8&9)

    Ok once again the problem was linked to this cross domain issue resolved few comments above.
    Finally there is no need for the cross domain plugin compatibility used in the previous solution.
    I included a fix for this kind of configuration straight into wysija.

    Hope this part will stay stable now πŸ™‚

    I am also getting this error when trying to send a test email. It sent a test OK two days ago using php send option, I tried doing a test on gmail today and I get the error below.
    Now I have changed the settings back to the php send and the error still remains.
    I am running the same plugins that I did two days back so I cant think what is causing the error. Any suggestions?

    Request error not JSON:
    <b>Notice</b>: Trying to get property of non-object in <b>/home/datetec/public_html/wp-content/plugins/wysija-newsletters/helpers/toolbox.php</b> on line <b>2</b>

    <b>Warning</b>: Cannot modify header information – headers already sent by (output started at /home/datetec/public_html/wp-content/plugins/wysija-newsletters/helpers/toolbox.php:2) in <b>/home/datetec/public_html/wp-content/plugins/wysija-newsletters/core/base.php</b> on line <b>165</b>
    {“result”:{“result”:false},”msgs”:{“error”:[“An error occured. Show more details.<\/a>”],”xdetailed-errors”:[“Subscriber not found : <b><i><\/i><\/b>”,”Subscriber not found : <b><i><\/i><\/b>”]}}

    Hi DateTec,

    This one is easy πŸ™‚
    Actually during install of wysija we automatically synchronise the wordpress users into wysija subscribers the list is called WordPress Synched.
    Apparently you’ve deleted those users, or to be more accurate the user corresponding to the administrator account you’re using to test the send mail.

    So to fix that it’s easy you just need to add a new subscriber with the same email of your wordpress admin account or simply edit-save your wordpress account, it should re synchronise it.

    Try that and let me know.

    Cheers,

    Ben

Viewing 15 replies - 1 through 15 (of 35 total)
  • The topic ‘[Resolved] [Plugin: Wysija Newsletters] Request error not JSON’ is closed to new replies.
Skip to toolbar