Support » Plugin: WPSSL (WordPress with SSL) » [Plugin: WPSSL (WordPress with SSL)] WPSSL and 3.1 – no secure pages

  • I installed and network-activated the latest WPSSL (WordPress with SSL), then as a quick test, hand-edited /wp-login.php and added in the right place

    <meta http-equiv="force_ssl" content="true" />

    Then I hit the login page and it’s not secured. Did I do something wrong? I did a “View Source” on the page and the meta tag is in place.

Viewing 4 replies - 1 through 4 (of 4 total)
  • By “not secured”, I mean the page comes up as http://blogname/wp-login.php instead of https://…. I was expecting it to be SSL automatically.

    I should also mention that I have a valid SSL cert that matches the hostname, and that https://myserver correctly displays the home page, secured.

    I was also wondering how to use this plugin, and I’m posting this in case you(or anyone else for that matter) has not already found the answer.

    Basically, I had never used the custom fields before when editing a page, and as of 3.1 I believe, the custom fields on the edit page are hidden by default. The installation instructions should be a bit moer clear and say that you need to add a custom field on the edit page, rather then editing the page and adding your own meta data tags(which it appears you attempted to do, and I also assumed was what was needed!)
    To add a custom field on your edit page, first un-hide them by clicking on “Screen Options” up in the top right hand corner of the edit screen. Next, check the box that says “Custom Fields”
    After you have checked that box, a new section will appear on your edit screen towards the bottom called “Custom Fields”
    In the “Name” section on the left, enter “force_ssl” and in the “Value” section on the right, enter “true” then update your page and you’re all set!

    I hope this helps save someone some time!

    Thank you very much =), ClintWK!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: WPSSL (WordPress with SSL)] WPSSL and 3.1 – no secure pages’ is closed to new replies.