Support » Plugin: WPSocialite » [Plugin: WPSocialite] Facebook stopped to load

  • Resolved zerpex

    (@zerpex)


    Hi,

    I did install this awesome plugin, and tmort helped me fixing some problem, because it didn’t load properly.

    Anyways, the last few days the facebook like buttons hasn’t really loaded for me.

    It loads all the resources, and I can see the iframe being injected into the page (White flash) – The problem is, that the facebook like button is hidden.

    I’m running SSL on my site, and I tried to disable it, to see if it was SSL causing it. But I found out it isn’t.

    Anyone else that have been experiencing this?

    Best regards,
    Lucas R

    http://wordpress.org/extend/plugins/wpsocialite/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Tom Morton

    (@tm3909)

    Lucas,

    Sorry I didn’t see this earlier. Can you tell me which version of the plugin you are using?

    I just pushed a newer version that has quite a few improvements. I would delete the current version and reinstall if all else fails.

    If that doesn’t work reply with a URL to your site so I can take a look at it directly.

    Again, apologies for the wait!

    It takes a long time to load. In 0.9 FB loaded randomly. Now with 1.2 the error I’m getting in Chrome is ‘XMLHttpRequest cannot load http://static.ak.fbcdn.net/rsrc.php/v2/y5/r/3WY-GP113Gi.js. Origin http://www.facebook.com is not allowed by Access-Control-Allow-Origin.’

    Plugin Author Tom Morton

    (@tm3909)

    That sounds like Facebook is failing to load because of a JSON error. The “Access Control Allow Origin” usually happens when you are trying to make a JSON request across a domain.

    I haven’t run into this before. Can you please post a URL to the site?

    Plugin Author Tom Morton

    (@tm3909)

    I’m closing this thread for now, but if anyone else has the above issues please reply here ASAP with the URL of the site as well as a detailed description of the issue.

    R J

    (@tzzel)

    Facebook Like Not Loading in Chrome

    Hi, I just found WP Socialize. Great plugin and I can tell that a lot of thought has gone into the loading process for it.

    My issue may be related to the OP’s. Right now, FB Like works on every browser except my Google Chrome. When I take a look at the console, I see these errors:

    Uncaught ReferenceError: Socialite is not defined http://www.thehawaiiplan.com:484
    Uncaught SyntaxError: Unexpected token { connect.facebook.net/en_GB/all.js:43
    Unknown RPC service: onstartinteraction

    Here’s a sample page: http://www.thehawaiiplan.com/whats-the-best-hawaiian-snack/

    I am totally clueless when it comes to loading. Any input would be appreciated.

    -RON

    Plugin Author Tom Morton

    (@tm3909)

    Ron,

    Welcome to the forum. I’m actually seeing the like button working when I visit the page you provided. See this video: http://screencast.com/t/ieiftFlcgxn

    Are you using chrome on windows or mac? Have you attempted to disable all other plugins except for WPSocialite, then activate them one by one, testing to see if one of them is causing an error?

    R J

    (@tzzel)

    Whoops! After you mentioned that it worked fine on your computer, I decided to try and delete all my history on Chrome. It ended up working, I guess because some old Facebook cache was causing an error.

    Sorry for wasting your time Tom. That was a pretty big oversight by me. Great plugin.

    Plugin Author Tom Morton

    (@tm3909)

    Not a waste of time at all, thats why the forum is here!

    Glad you like the plugin. I’m here if anything else should go awry.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: WPSocialite] Facebook stopped to load’ is closed to new replies.