WordPress.org

Support

Support » Plugins and Hacks » [Plugin: WPGPlus] Fatal error

[Plugin: WPGPlus] Fatal error

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author John Eckman

    @johneckman

    @muvimotv

    Looks like my error checking was not catching the first request – I have added that for 0.8.4 out in a few minutes. But that will just show a better error.

    Do you have debugging enabled, and was there a debug file created in your plug-in directory?

    The error at that line means the first request out to google plus failed – do you know if your server allows outbound http requests?

    Hey John!

    Thanks for you quick reply.

    No debugging is off, i’m on a shared hosting and the hosting company keeps on kicking me out for CPU usage over the limit so i try and keep it as low as possible…

    I just updated to 0.8.4 and now i’m having other troubles…

    I get too many redirects and it’s not posting anything and it’s even stopping other plugins to post updates too…

    I’ll see if i can do some testing for you with debugging enabled and will post back soon…

    the error i was getting was not systematic, i was only getting it now and then…

    And also i just checked and it seems that no updates have been posted since june 03…

    So I guess when i did one of the updates it must have broken something and the updates stopped…

    here is the error log i have:

    2012-07-05 09:58:59 : publish_to_gplus running, included wpgplus.php
    2012-07-05 09:58:59 : publish_to_gplus running, postID is 8414
    2012-07-05 09:58:59 : wgplus_safe_post_google running, post_id is 8414
    2012-07-05 09:58:59 : just requested the login info

    Buffer is
    WP_Error Object
    (
    [errors] => Array
    (
    [http_request_failed] => Array
    (
    [0] => Too many redirects.
    )

    )

    [error_data] => Array
    (
    )

    )

    Writing cookies from login get

    Plugin Author John Eckman

    @johneckman

    Couple of things might be happening here.

    What version of WordPress are you running?

    There was a bug which I believe was fixed in WP 3.2 which triggered a “Too Many Redirects” error when redirection was set to 0.

    There’s a plugin called Core Control ( http://wordpress.org/extend/plugins/core-control/ ) which includes, among other things, a module (external HTTP access) to tell you what HTTP transports your server supports (out of: cURL, PHP Streams, PHP fsockopen()) and any other constants/filter values which might be interfering.

    Some of the transports may still have issues with setting redirection to 0.

    It may be that when I updated the code to use wp_remote_request (and the WordPress HTTP API in general) you started to have problems (I think that was at 0.8?).

    On shared hosting with resource limits it may not be possible to run WPGPlus due to the number of requests it has to make – until Google releases a read-write API this is something of an expensive operation.

    I’m running WP 3.4.1.

    With 0.8.3, i didn’t have the too many redirects so i guess it must be coming from one of the last changes you must have done…

    I realized though as i was posting, like i mentioned before that none of the updates got posted after June 3rd so one of the changes you must have done around that period of time broke it for me…

    I installed core control and all 3 transports are supported and successfully tested.

    All the Constants are undefined and the filers set to the default values…

    Is there a place i can download your older versions? Maybe i should just step backwards until i find one that is working, that could give you a better idea where the issue could be coming from…

    It’s fine running WPGPlus on the share hosting, I just need to make sure that i don’t run too many things at the same time, but it’s not really an inconvenience…

    Thanks a lot for your help John!

    Plugin Author John Eckman

    @johneckman

    You can always get older versions from the WordPress plugin repo (for any plugin hosted there). Just go to http://wordpress.org/extend/plugins/wpgplus/download/

    for all the versions tagged in SVN.

    The only difference between 0.8.3 and 0.8.4 was setting redirection to 0 for the first wp_remote_request call, and checking for the WP_Error object (which is why you were getting a Fatal Error – because I was assuming the response was ok).

    You could try going back to 0.8.3 but enabling debugging to see what you get.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Plugin: WPGPlus] Fatal error’ is closed to new replies.