[resolved] Wpbook error when publishing a new post. (3 posts)

  1. Olivieri Maurizio
    Posted 3 years ago #

    Using the 2.4 version of Wpbook publishing a new post i got the following Wpbook error "Caught exception in publish to page (#200) Posts where the actor is a page cannot also include a target_id Error code: 0".
    Using the previous version the message was "Caught exception in stream publish for user: SSL read: error:00000000:lib(0):func(0):reason(0), errno 104Error code: 56"
    in both the cases the post is published on the facebook profile with a wrong image.
    Thanks for help


  2. John Eckman
    Plugin Author

    Posted 3 years ago #

    Hmm. The publishing to the profile with "a wrong image" is generally a separate issue.

    If you use WordPress "featured images" WPBook will pass the featured image (aka post thumbnail) to Facebook.

    If you don't use WordPress featured images, or don't set one for that post, Facebook will try to pick one, looking for Open Graph metadata on your posts - just like if someone shared that link directly. (This is also true if you post as links, since in that case the API doesn't accept images).

    In terms of the error, are you trying to publish to a page?

    What do you have set for Facebook Profile in your WPBook settings - is it your profile or a page ID?

  3. rbarcelo
    Posted 2 years ago #

    Hi johneckman,
    I have the same issue, In my case Iam trying publish to a page.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WPBook
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic