Support » Plugin: WPBook » [Plugin: WPBook] When I click publish, I get error in WordPress, but the post works in Facebook

  • Resolved Tim


    I must be doing something really dumb. I’ve read through a hundred posts on this website, and tried all the suggestions I could find, including disabling most of my plugins, and making sure that my server is running PHP5 (it is).

    When I click “Publish” in WordPress I get the following error:

    Caught exception in getting page type for page: 100000317110153 message was: Param page_ids must be a valid page ID Error code: 100

    I can click refresh/resend and or move on to another page, and the post will publish in both my WordPress blog and my Facebook wall. As I will not be the end user in all instances, I can’t have this error. It will confuse my end users, and I will receive never-ending calls and emails about the website “not working!”

    I don’t know if I somehow have the codes from Facebook input incorrectly, or if it’s the URL in the Facebook app, or if it’s the WPBook plugin itself.

    I’ve seen references that claim it has something to do with how Facebook doesn’t support this in Profiles any longer and that commenting out lines in the wpbook.php file will remedy this, but it didn’t work for me. Any ideas would be very much appreciated!!!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author John Eckman


    This doesn’t sound to me like it has anything to do with Profiles or commenting out any lines.

    This sounds like a settings error in one of two places (or both) in the WPBook settings inside WordPress.

    There’s a setting for “YOUR profile ID” and another for a “PageID” to which posts will be published.

    It looks like you are trying to publish to page 100000317110153, but that isn’t valid.

    What is the page you are trying to publish to?



    Hi John,

    The page I’m trying to post to can be found at the following URL:

    As I mentioned, the post will post, but I get this error every time, and WordPress goes to “”. If I refresh and resend, the error goes away, and WordPress acts as expected.

    In the meantime, whether I hit refresh or not, the post successfully posts to my facebook wall, too (which is GREAT). Other than this minor annoyance, this is a fantastic plugin!

    Because of the error I’m receiving, I suspected, as you point out that 100000317110153 isn’t a valid ID, but I’m not sure how to get a different ID. The numbers I input into WPBook are derived from clicking the “check permissions” links in the plugin. Is there another way I can determine these numbers? I’ve tried it several times with the plugin, and searched all my info on Facebook.

    As I first said, I’m probably just doing something dumb, but I guess I’m not smart enough to figure out exactly what that might be on my own! 😉

    I appreciate your kind response, and look forward to a little more guidance.

    Thanx and happy Friday!!



    Did I happen to mention that I was doing something dumb?

    After reading your post, I went back into my WPBook settings and swapped the IDs using what I THOUGHT was my wall ID in place of my profile ID and what I THOUGHT was my Profile ID in place of my wall ID, and it appears to be working now.

    I thought I’d tried this already, but I guess, again, I was doing something dumb instead….

    Thank you very much for your kind assistance, and a wonderful useful plugin!

    Operator error strikes again!

    Plugin Author John Eckman


    Funny, that’s just what I was going to suggest. Notice that there is an id in the url of the page itself – 185328761492537 – I assume the other is your profile ID.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: WPBook] When I click publish, I get error in WordPress, but the post works in Facebook’ is closed to new replies.