Support » Plugin: WPBook » [Plugin: WPBook] No Post ID returned from Facebook?

  • For some reason I am getting these errors back when I post a new post from WordPress. My posts are not showing up in wordpress correctly and I must go back and delete them.

    No post id returned from Facebook, $fb_response was /n and $fb_page_type was and $wpbook_description was and $my_title was Coyote Face

    http://wordpress.org/extend/plugins/wpbook/

Viewing 11 replies - 1 through 11 (of 11 total)
  • Please help.

    Thanks

    Plugin Author John Eckman

    (@johneckman)

    What does your “check permissions” page say? (WordPress->Settings->WPBook->Check Permissions)

    This is generally the result of a configuration error in either Facebook Profile ID or PageID.

    Thanks for replying.

    offline_access – yes
    read_stream – yes
    publish_stream – yes
    manage_pages – yes

    Plugin Author John Eckman

    (@johneckman)

    Not those parts, but the rest – what your FB profile ID is, and what is says *after* the part you cited.

    What is the page id you are trying to post to, and has the appropriate access token for that been stored?

    This page is where you can check and grant extended permissions, which enable WPBook to publish to your personal wall and/or to the walls of fan pages.

    The Facebook profile ID you are currently logged in to Facebook as is 1169597572. You have defined 1169597572 as your Facebook user id in WPBook Settings.

    FB profile 1169597572 has granted these permissions:

    offline_access – yes
    read_stream – yes
    publish_stream – yes
    manage_pages – yes

    An access token for this user has been stored.

    Plugin Author John Eckman

    (@johneckman)

    Are you trying to publish *only* to your own profile wall, or have you also put something in the fields for publishing to a page / group wall?

    Is there anything in your check permissions page after the user section?

    “To correct any of these, Grant or re-grant permissions for your userid. (This is required if you intend to publish to your personal wall OR any fan pages.)”

    I tried the ‘Grant or re-grant permissions’ link.

    Yes I did have the options selected to post to my profile wall and my fan page. It actually does post to the pages and works fine at the facebook level but causes strange errors in my wordpress.

    It may be my custom set up with wordpress. I am using PhotoQ and it seems like this may be where the problem is. After I post I can see them on the wall and on the fan page but I get errors in PhotoQ and it messes up the template.

    After I unchecked posting to my profile and fan page all is working fine. I just wondered if there was something that I was doing wrong. I don’t think there is but likely something conflicting with PhotoQ and WPbook.

    Thank you

    Plugin Author John Eckman

    (@johneckman)

    Could be – I don’t know anything about PhotoQ.

    The error you were posting about, and provided the error message for, is typically caused by someone putting the wrong thing in their WPBook settings as a PageID. (Something which isn’t a page ID but a profile ID, or a group ID, or what have you).

    It could also be caused by other problems, but that’s the most likely.

    Did you have debugging enabled? There should be a wpbook_pub_debug.txt file sitting in /plugins/wpbook/ that has more detailed info on what was happening when publishing.

    When you say:

    It actually does post to the pages and works fine at the facebook level but causes strange errors in my wordpress.

    What strange errors? The one you posted, or others?

    The post does not show on my front page or for that category on my wordpress I show excerpts on my fron page from various categories and then in order in each category, like I was mentioning it is a custom setup for my workflow, but the post does show at facebook. When I click the link at facebook it does take me to my page but some of my sidebars are missing.

    I then must delete the image from PhotoQ and delete the post, then everything straightens out.

    Once I de-select posting to wall or fan page, everything works fine. The app and all is back to normal.

    No I did not have debugging enabled.

    Next time that I try to post I will turn on debugging.

    The file you mentioned is not there cause I did not have it enabled. I was trying to fix around 4 am last night so I just did not have any more time to work on it any more.

    I thought that I followed the directions for getting the right page ID and profile ID and when I click the link it does take me to the right page and my wall at facebook, so I figured that these were right.

    Plugin Author John Eckman

    (@johneckman)

    @forestwander one quick thought which might help – if you are only publishing to the wall of your personal profile, the one linked to above, you don’t need to put that in as both a profile ID and page ID – just as a profile ID with that box checked.

    Some people I’ve seen put the same ID in both places – the other box is for a fan page ID or Facebook Group ID not an individual profile ID.

    Yes, I tried with the Fan Page ID in the proper field and the Profile ID in the proper field.

    Still got the same results.

    So then I tried each individually as a process of elimination and the only option which worked was to uncheck post to wall and fan page altogether.

    Thanks for your help.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Plugin: WPBook] No Post ID returned from Facebook?’ is closed to new replies.