Support » Plugins » [Plugin: WPBook] No comments.

Viewing 12 replies - 16 through 27 (of 27 total)
  • I deleted my Facebook app.
    Deactivated the plugin.
    Deleted the plugin.
    Created a new app.
    Installed the plugin.
    Activated the plugin.
    Entered the new app api and secret code.
    Double checked to make sure all settings were correct per the setup instructions.

    Nothing happens.
    I’m at a total loss.
    Here’s the app url
    http://apps.facebook.com/theviolent/

    What’s odd is that looking at the page source of your FB app, Facebook is calling the iFrame with just this src: http://theviolent.net/

    It should be calling the iFrame and passing in a number of parameters, including ?fb_sig_in_iframe=1 (and others – authorization, api key, etc).

    Not sure why – what are your application settings in Facebook? Is it set to a web application, iframe style?

    Yes, web application, Iframe, resizable.
    Here are the settings as listed from the config page.

    API Key
    94bc8630906ee2023cab8d266124e513
    Application ID
    129612363717659
    Contact Email
    giantslayer@theviolent.net
    Support Email
    giantslayer@theviolent.net
    Canvas Callback URL
    http://theviolent.net/
    Connect URL
    http://theviolent.net/
    Base Domain
    theviolent.net
    Canvas URL
    http://apps.facebook.com/theviolent/
    FBML/iframe
    iframe
    Developer Mode
    Off
    Application Type
    Website
    Private Install
    No

    Ok, I got the app working again. I found that I had selected the option for “New SDK’s” selected as I thought it was required for using the new social graph. I disabled that option and the app started working again.

    It even integrates nicely with the new social plugins from facebook.
    http://apps.facebook.com/theviolent/grunge/grunge-background-10

    Though, I am still having trouble with the link/url structure. Any ideas how I might trouble shoot this?

    And can you tell me where in your code is the call to post to the facebook wall for new posts?

    Thanks for all your help.

    I also noticed the page often has scroll bars the first time it loads and then a page refresh removes them. Is there any way to change this behavior?

    Thanks.

    What trouble are you having with the link/url structure?

    I don’t know what trouble you’re having in order to help troubleshoot.

    The code that posts to the Facebook wall is in wpbook.php in the (now misnamed) update profile boxes function.

    The FB app relies on Facebook’s own javascript to resize the iframe automatically at load time based on the size of the content – don’t know any way around that.

    What WPBook does is alter the permlinks to point to the posts inside your Facebook app rather than on the blog – it changes the domain to apps.facebook.com/your_app_name/ and then appends the permalink (like /2010/05/23/your-blog-post/) to that.

    In other words, it should be changing this: http://theviolent.net/poetry/deeper

    Into this: http://apps.facebook.com/theviolent/poetry/deeper

    When you post a comment you should get redirected back to your Facebook app not your site.

    Well mine won’t get converted but i get redirected back to my Blog post.

    FaceBook App
    http://apps.facebook.com/rushikeshblog/

    FB Home
    http://www.facebook.com/pixelkeeda

    Blog
    http://www.rushikesh.net/?p=82

    I believe I have gotten the links working. I still, however am not able to get the application to post to my fan page.

    I have=>
    1: added the app to the page.
    2: granted access to publish content to my wall.
    3: clicked the permissions link from wpbook.
    4: permissions link shows “theviolent.net (136789689670650), This page has granted stream.publish permissions to this app. “

    When posting to the fan page, the following error is generated.
    “Caught exception: Requires user session”

    Thanks for the help you have given.

    I believe there’s another thread on this same issue – not clear to me why some folks are hitting it and others aren’t, but a couple of people have been helping me troubleshoot, so I hope to have a patch release soon

    If you’d like to try the dev version go to http://wordpress.org/extend/plugins/wpbook/download/ and grab the “development version” from the bottom of that page.

    Once installed, go to WPBook settings – you’ll see there’s now a place to enter the target pageID, just like the target userID.

    Let me know if that works for you (it already works for me)

    I’ll give it a try. Thanks for all your help. And sorry for all the trouble.

    Works great!! Thanks for all your help.

Viewing 12 replies - 16 through 27 (of 27 total)
  • The topic ‘[Plugin: WPBook] No comments.’ is closed to new replies.