Support » Plugin: WPBook » [Plugin: WPBook] No Access Token for Publishing to Page

  • Resolved manuel90


    Can’t see where the problem is.
    Could somebody help me?

    When I tried to publish on my facebook profil and on my facebook page, ig ot this:
    2012-06-24 17:03:07 : publish_to_facebook running, target_admin is 100000171067928
    2012-06-24 17:03:07 : Post ID is 73
    2012-06-24 17:03:07 : My permalink is
    2012-06-24 17:03:07 : Get Post Thumbnail function does not exist, or no thumb
    2012-06-24 17:03:07 : Post thumbail is
    2012-06-24 17:03:07 : Post share link is
    2012-06-24 17:03:07 : Publishing to personal wall, admin is 100000171067928
    2012-06-24 17:03:07 : Publishing as excerpt, is
    2012-06-24 17:03:11 : Just published to api, fb_response is Array
    [id] => 100000171067928_489888544360177

    2012-06-24 17:03:11 : Past stream_publish, fb_response is Array
    [id] => 100000171067928_489888544360177

    2012-06-24 17:03:11 : No Access Token for Publishing to Page

    Thanks for the help

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author John Eckman


    The issue is that you have set WPBook to publish to a page, but you don’t have an access token for the page.

    When you visit your “check permissions” page in WPBook, does it say you have stored an access token for the page you’ve elected to publish to?

    What is the ID of the page to which you are trying to publish? Are you ad admin of that page?

    When i check permissions it goes like this:

    This page is where you can check and grant extended permissions, which enable WPBook to publish to your personal wall and/or to the walls of fan pages.

    The Facebook profile ID you are currently logged in to Facebook as is 100000171067928. You have defined 100000171067928 as your Facebook user id in WPBook Settings.

    FB profile 100000171067928 has granted these permissions:

    read_stream – yes
    publish_stream – yes
    manage_pages – yes
    user_groups – yes

    An access token for this user has been stored.

    You’ve indicated you wish to publish to this page: 258552957584793

    An access token corresponding to this page has been stored.

    There you also got the ID.

    Thanks for the quick answer

    Plugin Author John Eckman


    Hmm. Did it always say this?

    Is it possible you added the page id but never checked this permissions page after adding the page id? You have to recheck permissions if you change any of the publishing targets.

    The message shown on this page suggests that you have a page access token, while the message in debug suggests you do not. However, just visiting the “check permissions” page may actually have stored the page access token.

    Looking at your page:

    I see a few posts which look like they were made through the app – so perhaps the debug info was out of date?

    These are posts from another plugin which wasnt able to synch the comments. So I tried wpbooks
    I unchecked “posting to a page (with the right id)” saved it and checked it again…then i checked the permissions and nothing has changed. everything says “yes” like i said before.

    Oh, dont know what happend, but it works now!
    thank you very much.

    But i got another problem. The comments i make on the facebook page dont show up at wordpress and vice verca.

    Plugin Author John Eckman


    @manuel – as I said, just visiting the “Check Permissions” page generates the page access_token if you have the posting to page set when you visit it. Glad to see it working.

    The comment import works on an hourly basis, and depends on WP Cron working. Has it been more than an hour since you made the comment?

    Plugin Author John Eckman


    @manuel – as for “and vice versa” – WPBook will not push to your Facebook wall (or the wall of your page) the comments made in WordPress.

    Users viewing the canvas page app:

    Will be able to see all the comments (made in WordPress, or made in FB and imported to WordPress) on an individual post, for example:

    (note the extra “/” in the url – somewhere in one of your settings you have a trailing slash where you don’t need one)

    No, i’ve made it a few minutes ago,
    thank you very much so far!

    I’ll let you know when i face more problems

    Plugin Author John Eckman


    @manuel – if you do get further issues with comments import please open a new thread

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: WPBook] No Access Token for Publishing to Page’ is closed to new replies.