WordPress.org

Support

Support » Plugins and Hacks » [Plugin: WPBook Lite] Getting error "No post id returned from Facebook"

[Plugin: WPBook Lite] Getting error "No post id returned from Facebook"

  • AardvarkGirl
    Member

    @aardvarkgirl

    I accidently inserted my facebook page’s ID number where it says “YOUR” (as in your personal Facebook profile ID). Now I can’t change it… I can edit the number but there is no ‘save’ button, and of course I’m getting the error below.

    I have tried uninstalling the pluging but when I reinstall it it pre-enters all the data.

    How do I change the ID?

    No post id returned from Facebook, $fb_response was /n and $fb_page_type was and $wpbook_description was test test and $my_title was Test Post 3

Viewing 15 replies - 1 through 15 (of 22 total)
  • Are you sure there is no “save” button? Look all the way at the bottom of the form, above where it says “Need help?”

    AardvarkGirl
    Member

    @aardvarkgirl

    This is what I get…

    http://ratest5.com/WPbookLite.jpg

    I have deactivated / uninstalled / reinstalled and still this is what I get.

    When I completely uninstall (remove) the plugin, why does it remember the settings?

    Ah, I see – something is throwing an exception in trying to show the permissions on the page, so the admin page doesn’t get completely drawn, which means no Save button.

    (The uninstall routine must be failing to appropriately delete the old settings, which is why they aren’t going away when you uninstall)

    I’ll need to update WPBook lite to handle better what happens in the “page” section when there is incorrect data so you can fix your FB profile ID.

    (If you have direct db access, you can remove the “wpbookLiteAdminOptions” from your wp_options table – but I realize that can be a bit tricky)

    I’ve just updated to 1.2.1, which won’t fix the display of the admin page but should delete the options from the db.

    You’ll have to install it again, then uninstall and it should clear it’s db settings.

    I’ll also look at what error was occurring the admin page – thanks for the screenshot.

    I still get this error. I’ve used correct profile and page IDs.. using wpbooklite 1.2.4 with WordPress 3.1.3. It still throws

    @manu657 – are you are trying to publish to a page, or a group? What’s the ID of the thing you are trying to push to?

    Is your domain set correctly in your Facebook application?

    Is the personal profile you’re using (logged in to facebook as when you generate the access token) an admin of the page to which you are trying to publish?

    markandrewkato
    Member

    @markandrewkato

    Hi John,

    I have the same problem with manu657. In Facebook application, it says that it is required to have a secure page and secure canvas URL’s.

    Warning
    Secure Canvas URL will be required on October 1, 2011.
    Secure Page Tab URL will be required on October 1, 2011.

    Does this affect the plugin?

    Domains are set correctly. I’m logged in when I generated an access token. Here’s the group ID where I want to connect my WP with. “286963812356” (from http://www.facebook.com/groups/286963812356/)

    Any help?

    Thanks

    EDIT: BTW, when I’m generating an access code, it sends me to a blank page and it stops loading.

    The secure canvas URL and secure page tab url only apply if you are trying to have a canvas page or tab.

    That’s why WPBook Lite exists – in WPBook you would need SSL.

    In generating the access code, it should not be a fully blank page.

    You should get a permissions dialogue in facebook, telling you what permissions the app is requesting, then if you accept you should be sent back to your WordPress blog url with some additional stuff in the query string.

    At that point WordPress is fetching the access token in the background, and it should say at the top of the otherwise blank page something like “Success: access token saved” or “Failure: no access token.”

    In either case, you should see a link to return to your regular blog page.

    If you’re not seeing that behavior, something else is wrong. (I’m assuming you’ve already upgraded to 1.2.5, which behaves as I’ve described – 1.2.4 had a bug in the capture access token bit).

    What is the link destination of the “Generate Access” link, including all the query string bits?

    Are you getting anything in your PHP error log, when you try to generate tokens?

    markandrewkato
    Member

    @markandrewkato

    markandrewkato
    Member

    @markandrewkato

    I’ve already updated the plugin to 1.2.5. Here’s the previous error in the error log.

    [21-Feb-2012 03:54:29] PHP Fatal error: Cannot use object of type WP_Error as array in /home/raquelka/public_html/mmll2/wp-content/plugins/wpbook-lite/wpbook-lite.php on line 634

    I generated the token successfully. But still getting this error message.

    No post id returned from Facebook, $fb_response was /n and $fb_page_type was and $wpbook_description was test and $my_title was Facebook Test

    @johneckman I’m trying to post to a page which I’m an admin. I used my profile id for this. Do I need to change?

    @markandrewkato – that error referring to line 634 means you are not successfully generating (or retrieving) a token.

    The bit that comes back on the return url from Facebook (code=) is a code which WPBook Lite then uses to turn around and request, in the background, using wp_remote_request, an actual token.

    When you visit your WPBook Lite settings page, does it say it has a token stored? What does it say that token is?

    Unfortunately, the error isn’t giving us much useful info but it clearly shows that the wp_remote_request failed – basically the code is trying to get the access token out of the response but the response is a WordPress Error object instead.

    In short, the wp_remote_request is failing.

    Do you know if your web server is able to make requests to external sites via cURL or fopen?

    Did WPBook Lite *ever* work on your setup?

    I will need to create a new debug version which includes error checking on the wp_remote_request to find out what the WP_Error object contains.

    @manu657 What do you mean when you say you used your profile id for this?

    Where WPBook Lite asks for your profile id, put your profile id.

    Where WPBook Lite asks for a page ID, put the page ID.

    Have you updated to 1.2.5, and have you generated an access token since updating to 1.2.5?

    If so, what do you see when you load the WPBook Lite Settings page – does it say it has the proper access tokens it needs?

    @markandrewkato Just checked in a version of WPBook Lite which looks for that WP_error object in the response from wp_remote_request and outputs it.

    Can you install the development version from:
    http://wordpress.org/extend/plugins/wpbook-lite/download/

    And try generating an access token again? This should generate a more useful error than the blank page you’re getting now.

    markandrewkato
    Member

    @markandrewkato

    @johneckman I’ve tried the development version of the plugin. Installed it and filled all the required fields. Then when I clicked the grant access permission link, this error showed.

    Failed in creating access tokenResponse was Array ( [headers] => Array ( [access-control-allow-origin] => * [cache-control] => private, no-cache, no-store, must-revalidate [content-type] => text/plain; charset=UTF-8 [expires] => Sat, 01 Jan 2000 00:00:00 GMT [pragma] => no-cache [x-fb-rev] => 511645 [x-fb-debug] => kEv0aIqlTscPAZwuu4/8rsOAPL06I9Qh5QXAuI6fvBw= [connection] => close [content-length] => 143 ) [body] => access_token=AAAEkbV4LZAHIBAJ9ynZCw1YkBP64c5SyMzNFeJtk5qSL1qZAPysRx5Vh3kuUWbKtaE5wTKa57p01DAw9BJZC7Tnn1ZBcoyWXgZCLB8ZAY1BsQZDZD&expires=5136958 [response] => Array ( [code] => 200 [message] => OK ) [cookies] => Array ( ) [filename] => )

    Maybe that’s the thing you want to see.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Plugin: WPBook Lite] Getting error "No post id returned from Facebook"’ is closed to new replies.