WPBook Lite
[resolved] Blog articles don't show up in facebook (4 posts)

  1. Jack
    Posted 3 years ago #

    I know this is a difficult issue, because there are so many settings for this plugin, but I did it step by step, twice, and new articles don't show up in facebook. No error messages either.


  2. GNaschenweng
    Posted 3 years ago #

    I have the same issue - get the following errors in the debug log:

    Caught exception in stream publish for user: (#200) This API call requires a valid app_id.Error code: 0

    2012-01-07 10:24:04 : No access token
    2012-01-07 10:24:04 : publish_to_facebook running, target_admin is XXX
    2012-01-07 10:24:04 : Post ID is 1316
    2012-01-07 10:24:04 : My permalink is XXXX
    2012-01-07 10:24:04 : Function does not exist, or no thumb
    2012-01-07 10:24:04 : Post thumbail is
    2012-01-07 10:24:04 : Post share link is
    2012-01-07 10:24:04 : Publishing to personal wall, admin is XXX
    2012-01-07 10:24:04 : Publishing as excerpt, is

  3. John Eckman
    Plugin Author

    Posted 3 years ago #

    @moxie - you'll have to provide more info. Have you enabled debugging, and if so, what's in that file?

    @GNaschenweng - looks like you don't have an access token stored. When you visit the WPBook Lite settings page in Facebook, what does it say in the Permissions section?

  4. GNaschenweng
    Posted 3 years ago #

    @moxie - I managed to figure out why my push to FB did not work.

    - In the WPBook Lite Setup under "Required Settings"->YOUR Facebook Profile ID - I captured my pages ID instead of my Facebook ID.

    - Under "Stream Profile/Page Options" just click "Publish new posts to the wall of this page/group" and in the Page ID insert the Page ID of your FB page.

    Now everything works

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WPBook Lite
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic