Support » Plugin: WPBook » [Plugin: WPBook] Just my homepage in canvas iframe

Viewing 15 replies - 1 through 15 (of 26 total)
  • Plugin Contributor Brooke.

    (@bandonrandon)

    Which fields do you need help locating? I think Facebook may have changed the location of some of the settings and we’ll need to update the instructions. If you set up an application you should be able to edit the settings here http://www.facebook.com/developers/apps.php and find all the required infomation you’ll need to insert into WPBook.

    If you have more spacific questions let us know and we’ll try to help.

    I have the same problem… the entire blog is simply inserted into the iFrame instead of individual posts

    http://apps.facebook.com/thebilog/

    thanks

    bil

    Plugin Author John Eckman

    (@johneckman)

    I’m getting page not found for both http://apps.facebook.com/bloggdeto/ and http://apps.facebook.com/thebilog/
    so it is hard to troubleshoot.

    Generally we need to know:

    • The url of your blog outside facebook
    • The url of your app inside facebook
    • What you’ve provided in the settings for your Facebook application as the “canvas callback URL” or what FB now calls “canvas url” in the Facebook integration section of their settings
    • the version(s) of WordPress and WPBook installed

    Without most of this info it is difficult to even guess what may be wrong

    John

    I am having the same problem as the above two users for the app at http://apps.facebook.com/palermobakeshop/. The WP site is loading into the canvas formatted with the WP theme rather than the WPBook theme.

    I temporarily resolved it by setting canvas URL to http://palermobakery.com/?fb_force_mode=fbml and setting canvas type to iframe, which stopped the app from loading the site as is from http://palermobakery.com.

    I can show you the problem by deleting the “?fb_force_mode=fbml” appended to the end of the URL however, i cant leave the app like that (client site)

    It seems like the theme in the wpbook directory that should be formatting the posts for display on the app canvas is not functioning and I am simply forcing FBML mode. I don’t think the the theme is coming into play.. maybe?

    I am using WP 3.0.4 and WPBook version 2.0.9.2

    Plugin Author John Eckman

    (@johneckman)

    You should not have to set the canvas url to ?fb_force_mode=fbml – your app should be set to an iframe, which doesn’t require fbml.

    Trying to load http://palermobakery.com/?fb_sig_in_iframe=1, which should trigger the plugin, seems to get stuck in a loop. (The plugin checks for fb_sig_in_iframe, which Facebook adds when calling the blog inside a frame).

    I just tried it now and it seems to be working fine – not sure what setting you’re on at the moment. (But now I just tried again in another browser and got stuck in the auth loop).

    Leave the canvas setting as http://palermobakery.com/ but then let’s figure out why the plugin isn’t being triggered – have you tried disabling other plugins?

    Have you changed something about authentication?

    Plugin Author John Eckman

    (@johneckman)

    Odd – if I have loaded palermobakery.com in a browser tab, then apps.facebook.com/palermobakeshop loads fine.

    Are you using facebook connect for something else on the blog? seems like the blog is trying to set facebook cookies even outside FB – that might be related.

    Hey John..

    My app is set to load in an iframe.. I used the force FBML to make it look right for my client.

    I changed the canvas URL value to http://palermobakery.com/ also tried adding ?fb_sig_in_iframe=1 .. please have a look. the homepage is loading again in both cases.

    Yes.. SFC (simple facebook connect) .. witch i need to auto-login WP registrations. Let me turn it off and see if that changes the situation.

    SFC is actually using the same app ID/key secret as wpbook.. bad i dea i am guessing.

    ok.. SFC and associated SFC plugins are disabled..

    Turning off SFC didnt seem to make any difference.

    BTW.. some other points that might be related..

    I could not ever get the Plugin to correctly “check permissions”, “Grant Permissions for this user” or “Grant Permissions for this page” or get Infinite Session Key… in all these cases, clicking the link in the admin screen just loads the app page with the site in the iframe.

    The “permalinks on walls” setting doesn’t seem to actually create links to the WP site rather links to the APP.

    Clicking any post on the app page does not load up the post, it simply refreshes the canvas app (mind you this was when i had “force FBML” on the tail of the URL.. so may not be related)

    ..seeminglly I can recreate the listing on the tab http://www.facebook.com/pages/Palermos-Bakery/210200958157?v=app_164350866942617&ref=ts or load the website unaltered.

    .. lol.. sorry for inundating you.. but one other side note. The WPbook app last nite was posting the post image (note the post “”Marvel-ous DC” Superhero Specialty Cake:SC-30042″ on http://www.facebook.com/?ref=home#!/pages/Palermos-Bakery/210200958157?v=wall .. then this morning none of the new posts are successfully attaching the image.

    Again.. related?.. I am not sure.

    Would resetting the APP secret force WPbook to reconfirm the permissions?

    Plugin Author John Eckman

    (@johneckman)

    Definitely don’t want to have Simple Facebook Connect and WPBOok use the same ID/Key.

    Can you check your application settings inside Facebook, on the “advanced” tab, and tell me whether “OAuth 2.0 for Canvas” is enabled or disabled?

    I have the feeling Facebook’s switch in default on December 10th, to now use OAuth 2.0 authentication for the canvas page may be the problem – I’m hoping you can just set that to “disabled”

    Plugin Author John Eckman

    (@johneckman)

    Let’s get the basic iFrame loading correctly, then we can look into the other issues.

    That was is.. woo hoo!! .. actually two defaults had to be changed for it to work.

    OAuth 2.0 for Canvas – disabled
    POST for Canvas – disabled

    So everything on th advanced screen is diabled.. except
    November 2010 Rollup – enabled
    Timezone-less events – enabled

    So I need to set up a separate app for SFC..? In this case no problem.
    Thanks.. I have seen this issue in a few posts throughout the forum. I am sure this is the issue for everyone who has setup an WPBook app lately with FB defaults.

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘[Plugin: WPBook] Just my homepage in canvas iframe’ is closed to new replies.