Support » Plugin: WPBook » [Plugin: WPBook] FB Admined Pages not showing/PageID not working

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author John Eckman

    (@johneckman)

    So the pageid of your fanpage is NOT listed as one of the pages of which you are an admin?

    Have you added the application to the page?

    Go to this page: https://www.facebook.com/apps/application.php?id=104973709555900

    And click where it says “Add to Page,” choosing the appropriate page.

    Then go to your Fan page, and go into edit mode – do you see your fmnagencon app listed?

    Then look back in WPBook settings to see if the page now appears as one of the pages of which you are an admin so that you can grant permissions to it.

    Hi John, Thanks for your response.
    Yes, my fan page was not listed as one of the pages I am an admin of.

    Before writing my first message I added the application to the page, as you have stated above, repeatedly thinking I might have missed something but it did not show up in the fan page edit mode.

    After getting your response I tried again and it did show up!

    Now when I click grant permissions I get this. (I have included what was in the address bar in case that gives any clues.)

    http://skitch.com/shackep/dqu6q/facebook-error-1-1

    Once I click “Okay” I get:

    http://skitch.com/shackep/dqu9n/facebook-page-not-found

    Thanks again.
    Peter

    Plugin Author John Eckman

    (@johneckman)

    Thanks – very helpful diagnostics.

    This is a bug in WPBook 2.0.1.

    I’m checking in a fix for it now – so you’ll need to grab the “development” version later today – I believe these are updated every 15 minutes? ( http://downloads.wordpress.org/plugin/wpbook.zip )

    If you’re comfortable making the change yourself, change lines 117 an 118 to be:

    echo 'http://apps.facebook.com/'. urlencode($wpbookAdminOptions['fb_app_url']);
    echo '/?wpbook=catch_perms&extern=1&display=popup&ext_perm=publish_stream&enable_profile_selector=1&profile_selector_ids=';

    (adding the apps.facebook.com bit before the fb_app_url, and adding a ‘/’ before the ?wpbook= stuff

    Yes, I made the change and this resolved that issue for me. Thanks. It took a little hunting to figure out I was to add the above code to the index.php in themes.

    Now this is where things are at:

    http://img.skitch.com/20100729-eicnct8ddpny6ufdikx1nun5be.png

    My best guess would be that FB is trying to pull in the theme css along with the content, which is throwing up parsing errors?

    Peter

    Plugin Author John Eckman

    (@johneckman)

    Looks like you are trying to load WPBook in a tab.

    WPBook doesn’t support tabs.

    Tabs only allow FBML, which means no css, no javascript, no iframe, etc.

    I’m think I’m in the same boat. WPBook is posting *new* WP articles successfully to my FB Wall, but it’s not clear to me where on the Page I can display the pre-existing WP posts (which are being pulled in so nicely to the FB app).

    I added the app to the Page and FB just put it in a new tab by default – didn’t give me any choices about Boxes as seen in the figure in the “Socialize Options” section of the Installation Instructions of the plugin…

    Plugin Author John Eckman

    (@johneckman)

    ydrecords – looks like Facebook has changed how Page profiles work, and no longer allows the FBML box in the main profile as it used to. (Which then let you choose between putting the “Recent Posts” box in your “Boxes” tab or having it on your main profile).

    I will need to revise how WPBook creates this tab for pages.

    Plugin Author John Eckman

    (@johneckman)

    Check out WPBook 2.0.2 – added support for tabs.

    You have to add this to the tab url setting in fb:
    ?app_tab=true&fb_force_mode=fbml

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: WPBook] FB Admined Pages not showing/PageID not working’ is closed to new replies.