Support » Plugin: WPBook » [Plugin: WPBook] Exceptionerror in WordPress by publishing posting

Viewing 14 replies - 1 through 14 (of 14 total)
  • the testposting that I tried to post was not published in facebook. In the blog itselves it was published. Because it was only a test I’ve deleted it in the meantime.

    Plugin Author John Eckman

    (@johneckman)

    The incorrect signature code would suggest that you haven’t updated your API Key and Secret to match your new FB application.

    Not sure why the redirects are sending you outside the FB iFrame, but it looks like you have a “post-authorize” url set up somewhere in your FB application settings.

    Want to add me as a developer on this new FB app so I can look at the settings, and update your WordPress WPBook settings with the new API Key and Secret?

    Now you are an additional developer of the new facebook-app called simply “Baden gospelt”. I mean that in wordpress there is only requested for the apikey. The “post-authorize”-URL is empty.

    I’m a little bit confused because the error seems to be like the same that I have before I build a new facebook-app that you suggested some time ago. The only changed is the exeption 104-error and the fact that the redirected URLs doesn’t break up loading yet while displaying the frontpage of the blog.

    If you want I can send you a screenshot of the wpbooksettings in wordpress.

    possible I have to activate the facebook-app. I found that the secretkey was wrong. I corrected that and now I get this error by publishing a post in wordpress:

    Caught exception in stream publish for user: The user hasn’t authorized the application to perform this actionError code: 200

    Ok in the meantime I granted permissions for the facebook-app. In Facebook I was told to click on the link grant for userID. The link I’ve clicked on. Now in wordpress I get this error when I want to publish a new blogpost:

    Caught exception in checking extended permissions for page: User must have accepted TOS Error code: 200

    I don’t find any key that enables that I can get tos-errors. I looked into the wordpress-settings and looked into the settings of the facebook-setting. I’m woundering and confused.

    Plugin Author John Eckman

    (@johneckman)

    Rupert – it seems like the new Facebook app has eliminated whatever issues you were having with the redirect loop.

    If I visit the Facebook application: http://apps.facebook.com/badengospelt/

    I see a set of recent posts. Clicking on the title of one of those posts loads its permalink, like: http://apps.facebook.com/badengospelt/2010/07/chormitglied-seiner-hochzeit-begospelt/

    Which loads perfectly well in FB, as expected – no weird redirects.

    The problem you’re facing now, the “Caught exception in checking extended permissions for page: User must have accepted TOS” is because the app has not been added to the page in question – the page has not authorized the app.

    When you load the “check permissions” page – http://apps.facebook.com/badengospelt/?is_permissions=true – what do you see?

    Does it say something like:

    You are also listed as the admin of these pages:

    * Page name (numeric id), This page has NOT granted stream.publish permissions to this app. Grant stream.publish for this page.

    You can use the page IDs of any of these pages in the WPBook settings to publish to that page’s wall.

    If you are the administrator of pages which do not show up in this list, you need to ensure you have added the application to the pages first.

    Does it list the FB page you are trying to publish to?

    If not, then that is the problem – for some reason adding apps to the page seems to have changed. It used to be that from the Application’s profile page (https://www.facebook.com/apps/application.php?id=136534616382539) you could click on Add to My Page, and it would take you to the page and do the add.

    Now it seems to get stuck at the point of “add to my page” and stop there – that’s something I will need to look into.

    Error seems to be a communicationproblem with facebook or within the wordpressplugin. I found a new backlink ceated on the personal wall and after clicking on it the blogpost was well embedded into the facebooklayout.

    Plugin Author John Eckman

    (@johneckman)

    Actually, that’s not true – it just worked fine for me.

    Going to the Applications profile page: https://www.facebook.com/apps/application.php?id=136534616382539

    Clicking on “Add to my page” in the left column under the “Go to Application” button results in a popup listing pages to which I could add the app.

    I clicked on one of those pages (https://www.facebook.com/pages/WPBook/44062579871) and then “close.”

    Then I went to that page, and went into “Edit page” mode.

    I see “Baden Gospelt” listed there as one of the applications on the page, and click the “edit” button associated with that app, which takes me to a url which looks like this: http://apps.facebook.com/badengospelt/?fb_page_id=44062579871

    That page loads with a message that says something like “you’ve now added the application to your page” – basically a success message.

    Have you done this process for the page to which you are trying to publish?

    Plugin Author John Eckman

    (@johneckman)

    rhelms – any update here?

    If you’re still having trouble, please try updating to WPBook 2.0.2 and following the detailed instructions for settings in it.

    I’ve just updated to wpbook 2.02. Backlinks in the personal wall are not the problem. But with the fanpage I’ve still problems inside wordpress (TOS-error)

    That is the message I get back in wordpress after publishing a new post:

    Caught exception in checking extended permissions for page: User must have accepted TOS Error code: 200

    After updating to 2.0.2 I’ve in addition warnings for wrong headerinformations relating to wpbook.php. I tried granting new permissions in facebook for wpbook 2.0.2 and also in the facebookgrantingpage I was informed about headerproblems in wpbook.

    plugin is disabled now because of possible blogcrashes.

    Plugin Author John Eckman

    (@johneckman)

    rhelms – sorry, late night hacking on weekends got the better of me.

    There’s a 2.0.3 now, 2.0.4 later tonight or tomorrow.

    2.0.3 fixes the header information bug, 2.0.4 will fix the “publish meta was yes” referred to in another thread on this forum

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Plugin: WPBook] Exceptionerror in WordPress by publishing posting’ is closed to new replies.