Support » Plugin: WPBook » [Plugin: WPBook] Blog Post not Posting to Facebook Profile

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author John Eckman

    (@johneckman)

    First, are you using WPBook or WPBook Lite?

    This is the forum for WPBook – there’s a corresponding one for WPBook Lite at: http://wordpress.org/tags/wpbook-lite?forum_id=10

    Second: do you have debugging enabled?

    Is there a debug.txt or debug_pub.txt in your wpbook (or wpbook-lite) folder?

    If WPBook-Lite: what is shown on your WPBook Lite settings page in Facebook in terms of publishing destinations and access tokens?

    If WPBook: What is shown in your “check permissions” page inside WPBook Settings?

    Plugin Author John Eckman

    (@johneckman)

    Finally, are you only trying to publish to your individual profile page, or to a fan page / group?

    If you look at your Facebook timeline, and switch to “activity log” do you see your post there?

    mcmonty

    (@bradloveinpursuitme)

    – Sorry, I followed the support link at the bottom of the WPBookLite settings page which took me to the main WPBook plugin page.
    – Yes. Here it is:

    2012-02-21 21:18:21 : publish_to_facebook running, target_admin is *********
    2012-02-21 21:18:21 : Post ID is 639
    2012-02-21 21:18:21 : My permalink is http://loveinpursuit.me/blog/full-steam-ahead
    2012-02-21 21:18:21 : Function does not exist, or no thumb
    2012-02-21 21:18:21 : Post thumbail is
    2012-02-21 21:18:21 : Post share link is
    2012-02-21 21:18:21 : Publishing to personal wall, admin is *********
    2012-02-21 21:18:21 : Publishing as excerpt,  is
    2012-02-21 21:18:21 : Past stream_publish, fb_response is

    – Publish new post to wall.
    – Publish as posts.
    – Individual profile page.
    – I do not have timeline enabled in Facebook.

    Plugin Author John Eckman

    (@johneckman)

    Ah, thanks – I’ll update the support link at the bottom of the page to point to WPBook Lite rather than WPBook.

    Did you edit the “fb_response is” line?

    Something quite funky is going on there – there should be a bunch more right after fb_response – basically telling us what the FB API responded to use with when we called it.

    I may need to make yet another debug version with more info in it – if your debug file just ends like that it probably means we got no good response from Facebook.

    mcmonty

    (@bradloveinpursuitme)

    I only removed the ********* section.

    Plugin Author John Eckman

    (@johneckman)

    I’m working on a new debug version – be done in a day or two – which will include a specific try/catch around each specific call to the API – so we can see what kind of error it is throwing (or not throwing as the case may be).

    mcmonty

    (@bradloveinpursuitme)

    Thanks. I appreciate your commitment to resolving this issue!

    Plugin Author John Eckman

    (@johneckman)

    New development version posted now – please install and try, with “Show Errors publishing to Facebook stream” checked in your WPBook Lite settings.

    I cleaned up all the calls to the Facebook publish API so that they have a specific try/catch block around them, which should throw a useful error if they are getting no data.

    I’ll warn you that sometimes Facebook error messages are less helpful – but usually it gives me enough clue to go on.

    mcmonty

    (@bradloveinpursuitme)

    The only one I see is 1.2.5 which says it was added 6 days ago. Is this the one you are referring to?

    Plugin Author John Eckman

    (@johneckman)

    Not 1.2.5.

    If you click on “other versions” over to the right on the plugin page, or go to wordpress.org/extend/plugins/wpbook-lite/download/

    (just add /download/ to the end of the plugin page)

    You’ll see the full list of versions, and down at the bottom of that list is the “development” version which is basically live against the source control repository.

    mcmonty

    (@bradloveinpursuitme)

    Sorry for the delay in responding.

    2012-02-28 21:31:03 : publish_to_facebook running, target_admin is ********
    2012-02-28 21:31:03 : Post ID is 692
    2012-02-28 21:31:03 : My permalink is http://loveinpursuit.me/blog/you-wont-relent
    2012-02-28 21:31:03 : Function does not exist, or no thumb
    2012-02-28 21:31:03 : Post thumbail is
    2012-02-28 21:31:03 : Post share link is
    2012-02-28 21:31:03 : Publishing to personal wall, admin is ********
    2012-02-28 21:31:03 : Publishing as post, my_image is
    2012-02-28 21:31:04 : Just published to api, fb_response is
    2012-02-28 21:31:04 : Past stream_publish, fb_response is

    Appreciate you exploring this issue.

    mcmonty

    (@bradloveinpursuitme)

    It also said

    Caught exception publishing to user profile as post: Error validating application.Error code: 0

    while publishing the post.

    Plugin Author John Eckman

    (@johneckman)

    @mcmonty – this was using the new development version of wpbook-lite, yes?

    The “Publishing as post” line would seem to be from an older version

    And you have “show errors posting to Facebook” checked on the WordPress side, in WPBook settings?

    It looks like, from what you’ve posted above from the debug, like FB is just not responding to the posts – not with an error but also not with success – not sure how to deal with that.

    Have you re-created your access token since updating to 1.2.5 or later (dev version)?

    Is it possible some PHP error is being thrown when publishing?

    Plugin Author John Eckman

    (@johneckman)

    Ah, the plot thickens.

    Where it said “Error validating application” at least that is a clue – that is why it is not allowing the post through to Facebook, because it doesn’t see the access_token you have as valid, or for some other reason can’t validate the application.

    Have you re-generated your access token recently? (Since moving to 1.2.5 at least)

    Can you check your access token (it should be visible on the WPBook Lite settings page) here:

    http://developers.facebook.com/tools/debug

    mcmonty

    (@bradloveinpursuitme)

    I’ve generated a new one. Then pasted it in the debug field you provided. Facebook then says ‘error.’ Obviously, this is an issue regarding Facebook..and not your plugin. However, I would appreciate any advice you could provide as to my next step.

    Thank you!

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘[Plugin: WPBook] Blog Post not Posting to Facebook Profile’ is closed to new replies.