WordPress.org

Support

Support » Plugins and Hacks » WPBook » [Plugin: WPBook] 2.1 not working

[Plugin: WPBook] 2.1 not working

  • Hi, this is my first time using WPBook. I followed the instruction under the “1.Basic Facebook Application Setup and Plugin Activation”. After I have set up the application, I tried accessing the apps page (http://apps.facebook.com/jacksonphang/), it keeps refreshing and is unable to load any contents.

    Without being able to access the apps page, I am unable to authorize postings to FB. Please help. Thanks.

Viewing 15 replies - 1 through 15 (of 29 total)
  • I can confirm that wpbook 2.1 is not working. Used the previous version, everything worked fine. Now on Facebook there’s a blank page … Had to go back to stable version 2.0.13

    Plugin Contributor BandonRandon

    @bandonrandon

    make sure you have OAuth enabled in your advanced settings inside Facebook

    Just to add on, when I deactivate WPBook, I am able to load the apps page. But when I activated it, the apps page goes on refreshing continuously again.

    Hope above gives more insight to the problem I am facing.

    Thanks Bandon. The apps page is working now.

    However, there is a new problem. I’ve completed the steps and granted the permission to publish new posts to my wall. I published a new post and it doesn’t appear on my FB profile (http://www.facebook.com/jackson.phang). Need some help. Thanks.

    I am getting this error code when I try to publish new posts,

    Fatal error: Call to undefined function get_the_post_thumbnail() in /home/jacksonp/public_html/wp-content/plugins/wpbook/includes/publish_to_facebook.php on line 72

    Still the wpbook 2.1 version gives a blank page. What has changed exactly in the settings and could you be more precise about OAuth?

    christian, bandon meant enabling the “OAuth 2.0 for Canvas” under the advanced tab in the facebook apps settings.

    Plugin Author John Eckman

    @johneckman

    @jphang – see the other thread here in the forums.

    Adding:
    add_theme_support( 'post-thumbnails' );

    To the functions.php in your theme (your normal theme outside FB)

    Seems like that function may be undefined *if* your theme does not support post thumbnails

    @jphang Tnx, I thougt so, so I tried that allready, but it has no effect! Still the blank page. When I go back to version 2.0.13 everything is fine ….

    hi john, thanks, i added it to the function.php and the error message is gone. However, i still do not have the excerpts on my profile page and I am not getting any error message… any other ways?

    Plugin Author John Eckman

    @johneckman

    @jphang – have you gone to the check permission screen? What does it say?

    @christianebuddy – did you go through the changes outlined in the posts linked to here:
    http://www.openparenthesis.org/2011/03/14/wpbook-2-1-released

    Specifically the change of API Key to app id, and enabling OAuth for canvas?

    Were you using WPBook in older versions?

    hi john, i’ve checked the permission.

    This user_id has granted these permissions:

    •offline_access – yes
    •read_stream – yes
    •publish_stream – yes

    i think everything is ok, except that i don’t know why they don’t appear on my wall.

    Plugin Author John Eckman

    @johneckman

    Does it say, on that page:

    This user has set an access_token for the application to use.

    Are the user profile id and page id both set correctly?

    Have you published a new post?

    Was the “Publish this post to Facebook Wall?” box set to “yes” in the post edit screen when the post was published?

    Which wall are you trying to post to – your personal profile, or a group/page/application wall?

    Thanks for the prompt response john.

    Yes, the page does say “This user has set an access_token for the application to use.”

    Yes, I’ve copied and paste the profile id. I only chose to publish to my personal profile page and did not set the page id.

    Yes, I tried a couple of times publishing new post.

    Yes, the box was definitely checked yes.

    Personal profile.

    I update and is not working 🙁

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘[Plugin: WPBook] 2.1 not working’ is closed to new replies.
Skip to toolbar