Support » Requests and Feedback » [Plugin: WPaudio MP3 Player] Bugs and suggestions

  • Just thought I could help you out with some bugs.

    1. text=”” doesnt seem to support symbols like &.
    2. couldn’t get the converter from audio-tags to work. I did have artists= and titles= info in my audio:tags, maybe this has something to do with it?

    And finally just a suggestion. when clicked on new song, pause the one playing.

    otherwise: GREAT plugin, very easy to modify even without “css-support”

    Can be viewed at http://www.goodbadmemories.com (quite heavily styled though, with different gif also)

    Thanks!

    http://wordpress.org/extend/plugins/wpaudio-mp3-player/

Viewing 15 replies - 16 through 30 (of 88 total)
  • drkareilly, Brian was using a custom theme that didn’t include some essential WP functions on which WPaudio depends. If you want to shoot me the source or link for a page with errors, I’ll be happy to check it out.

    Bourkela, were you using the Audio Player plugin? Those are the only tags supported at the moment, but support for others is easy to add if you want to send me the details for your tags, I’ll get them supported. I should add the option to convert mp3 links too, eh?

    Jurimaru, glad you like it! I’m adding more options, and I’m looking into the WP media dialog so tags can be added without manual typing the [wpaudio] syntax. The stop button behavior can be replicated by jogging to the very end of the track, then pressing play once the song has finished. I won’t be adding a stop button for now, but I will keep your feedback in mind and add one if I receive more requests for it.

    Hi Todd,thanks for the response. The site I am trying to use your plugin on is: http://negleycompositions.com/realmusic/media/audio/.

    If you need more info, I can email it to you. Thanks for checking it out. I think the custom theme is my issue. 🙂

    Kate

    Hi Todd,

    I am using the Audio Player plugin…Maybe I did something wrong though; I’ll try again.

    Yes, an option to encode the mp3 links would be awesome. I’m creating a site for a songwriter who doesn’t want the mp3s available for free.

    Thanks for your work on this plugin!

    Leslie

    Bourkela, regarding download option – you should add dl=”0″ option to your [wpaudio … ] tag. This will disable link to media itself. Another option is store mp3’s under a random filename – md5 hash for instance.
    You have to choose between content availability and security. In case you still want to provide link to somebody you need to assure that this link will be available only for that person, which is hard to do.

    Hi Todd,

    Yup, I have ended up in the same situation as Brian and Kate… Suspect I did something to my theme…
    This is the website:
    instrument-studio
    and here is an example of a post:
    wpp

    Any pointers would be greatly appreciated!

    Cheers

    Mikkel

    Leslie, if you’d like to email me your code or a link to an example, I’ll be happy to take a look at it.

    I’m going to encode the mp3 URLs so they’re not visible in the source, which would make it more inconvenient to find the actual URL.

    For instance, one of my mp3 URLs just became \u0068\u0074\u0074\u0070\u003a\u002f\u002f\u0077\u0077\u0077....

    Mikkel, what happened to your theme? Your individual post is missing everything but the content — no head, no body.

    WPaudio requires wp_head() in the <head> section to call the scripts it needs.

    Hi Todd,
    Thanks for replying so fast!
    I’m loading my posts through an iframe on the home page. In order not to have the header show up twice (once inside the iframe, once on the home page), I stripped my posts of everything bar the content.
    You’re saying that I need to call the header in my posts for WPaudio to work?

    Mikkel

    You don’t need any other parts of your site that normally appear below the <body> tag, but try wrapping your current post with:

    <html><head><?php wp_head(); ?></head><body>
    
    (your current code)
    
    </body></html>

    Todd.. can you please help me with this problem?
    If you look on my page http://beatdistrict.nl/?p=18) then you’ll see the lay-out of the player isn’t the way it has to be. What can I do?

    Thanks

    fffbbb, I’m not really sure why it’s behaving that way. Your entire post looks to be wrapped in a <pre> element, so you might try removing that and seeing what happens.

    Thank you for your fast reply. I removed the
    pre element but than the “play” icon doesn’t work anymore.

    Hi Todd,
    Thank you very much for your help – that did the trick perfectly.

    I really like the minimalist design – it fits my website perfectly, but I was wondering about a few things:
    1/ Is it possible to place several instances of the player on the same line? As in:
    WPPlayer / WPPlayer / WPPlayer / WPPlayer

    2/ Is there any way of NOT having the title become a clickable link?

    Cheers

    Mikkel

    Mikkel, currently you can have just one player per line. To disable downloading, just add dl="0" to your tags.

    [wpaudio url="http://url.to/your.mp3" dl="0"]

    Just installed wpaudio on my WordPress 2.8.4 blog, with the inove theme. The Player shows up, but whenever I click on the play button it just doesn’t happen anything! I thought it’s a problem with my Browser, but Firefox, Safari or even Internet Explorer do not work.
    I can click on the link to download the mp3 or play it just fine, so the path is correct.
    Am I missing something?

    Thanks!

Viewing 15 replies - 16 through 30 (of 88 total)
  • The topic ‘[Plugin: WPaudio MP3 Player] Bugs and suggestions’ is closed to new replies.