WordPress.org

Support

Support » Plugins and Hacks » WP Zend Library » [Plugin: WP Zend Library] PHP 5.3 required …

[Plugin: WP Zend Library] PHP 5.3 required …

  • … since you use __DIR__
    Better use dirname(__FILE__), which works with PHP <5.3

    I dont get, why you use the config file for the db acount data. I changed it to use the WP constants from wp-config.php. Works pretty good.

    However … its a great plugin. I was just thinking of doing exactly the same, when I found this in the plugins pool.

    Thank you!

    http://wordpress.org/extend/plugins/wp-zend-library/

Viewing 2 replies - 1 through 2 (of 2 total)
  • You just need to add that line at the start of wp-zend-library.php to use it on PHP 5.2 server :

    if(!defined(__DIR__)) define('__DIR__',dirname(__FILE_));

    I am getting below error
    Warning: fopen(http://framework.zend.com/api/zf-version) [function.fopen]: failed to open stream: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. in C:\wamp\www\wordpress\wp-content\plugins\wp-zend-library\library\Zend\Version.php on line 72
    i m passing below parametres in config.ini file

    ;<?php exit; // do not remove ?>

    [main]
    ; Database connection settings
    ; Database functionality is automatically disabled if any of these settings are blank.
    ; for available adapters see http://framework.zend.com/manual/en/zend.db.adapter.html
    ;
    db.adapter = PDO_MYSQL
    db.params.host = localhost
    db.params.dbname = wordpress
    db.params.username = root
    db.params.password =

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Plugin: WP Zend Library] PHP 5.3 required …’ is closed to new replies.
Skip to toolbar