Support » Plugin: WP YouTube Lyte » [Plugin: WP YouTube Lyte] Lazy Load issues

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author Frank Goossens

    (@futtta)

    Tha is … Interesting. What lazy load plugin do you use? Can it be configured not to act on specific types of images?

    Plugin Author Frank Goossens

    (@futtta)

    fyi: just tested with lazy load, no problem there, cfr. this demo-page.

    i’ll be happy to test with another lazy-load plugin or to look into this problem on your blog (if you provide me with the URL, that is).

    if you want, you can also reach my on my futtta at gmail-address.

    Hello,
    I have testet it with both plugins:
    – Lazy Load
    – jQuery lazy load plugin
    I provide it online now on
    http://bigbossdesign.de/scrum-in-der-praxis/
    You see two Youtube movies embedded. The first with use of Youtube Lyte, the second without.

    Must check if there are dependencies to other plugins. I suspect Cachify. Tell you soon my results.

    Plugin Author Frank Goossens

    (@futtta)

    ok, i’m very curious as to who broke my plugin! 😉

    Plugin Author Frank Goossens

    (@futtta)

    don’t know who’s to blame, but all lyte-initiating javascript in the lyte-div is … gone;

    <div class="lyte" id="WYL_0Nuj-GgEW6o" style="width:640px;height:480px;"><noscript><a href="http://youtu.be/0Nuj-GgEW6o"><img src="http://bigbossdesign.de/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="http://img.youtube.com/vi/0Nuj-GgEW6o/0.jpg" alt="" width="640" height="480" />Dieses Video auf YouTube ansehen.</a></noscript><script type="text/javascript"></script></div>

    Woho, no Javascript?
    Maybe it is the plugin: Better WordPress Minify? I will try.

    Oops »Internal Server Error«? I’ll be in touch later…

    Ok I am in again.
    Seems, that compression/optimization tools dont like WP YouTube Lyte?

    Tried some Plugins:

    Cachify deactivated -> WP YouTube Lyte works
    Cachify active -> failure

    Autoptimize deactivated -> WP YouTube Lyte works
    Autoptimize active -> failure

    PS: Site runs now with Autoptimize

    Plugin Author Frank Goossens

    (@futtta)

    I use css-js-booster myself, no problem there. But if other optimizers remove the initializing javascript in the lyte-div, WP YouTube Lyte can’t work, because it’s … javascript-initialized 🙂

    Removing inline javascript in the body should be a no-go for optimizers, or at least an option that one can turn off. So I installed Autoptimize and behold, it has the option “Look for scripts only in <head>?”. If you enable that, the inline javascript isn’t removed and all is well.

    Hey, I have followed your instructions and all is well. Thank you very much for your quick assists!
    All the best 4now!

    Plugin Author Frank Goossens

    (@futtta)

    great!

    don’t know if it was you who marked 0.9.3 as “broken” on wordpress 3.2 in the “compatibility”-box, but if so, would you care to adjust now that we’ve been able to solve you probs? and if it was not you, well, it would be great if you could confirm it works (and maybe even rate)? 🙂

    Hello you are right — voting and stars to be corrected — and on the way! 5 Star-Rating for support (but 4 stars for inline javascript?).

    Plugin Author Frank Goossens

    (@futtta)

    I can live with 4 stars 😉

    But I see one small quirk on your blog; the transparency of the play-button is wrong. If you update wp-content/plugins/wp-youtube-lyte/lyte/lyte.css, replacing

    .lyte img {border:0px;padding:0px;spacing:0px;margin:0px;display:inline;}

    with

    .lyte img {border:0px;padding:0px;spacing:0px;margin:0px;display:inline;background-color:transparent;}

    That should be solved as well. I’ll make sure that tweak makes it to the new version.

    Done and all great!

    Plugin Author Frank Goossens

    (@futtta)

    hi dubbelstein; the inlinve javascript has disappeared in version 1.1.0, so I’ll have that 5-star rating now 😉

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Plugin: WP YouTube Lyte] Lazy Load issues’ is closed to new replies.