Support » Plugins and Hacks » [Plugin: WP Widget Cache] Problem since .25 version of plugin

  • I upgraded the widget-cache plugin today, but now all i get on my widgets are these errors. Any ideas on what to do?:

    Warning: mkdir() expects at most 2 parameters, 3 given in /home/quick42/public_html/biblemoneymatters/wp-content/plugins/wp-widget-cache/inc/wcache.class.php on line 84

    Warning: fopen(/home/quick42/public_html/biblemoneymatters/wp-content/widget-cache/acc395808606926b0dd1738785822e0e/acedd2fbf7e7ffdb8f4738d4b6475d9b) [function.fopen]: failed to open stream: No such file or directory in /home/quick42/public_html/biblemoneymatters/wp-content/plugins/wp-widget-cache/inc/wcache.class.php on line 142

    Warning: flock(): supplied argument is not a valid stream resource in /home/quick42/public_html/biblemoneymatters/wp-content/plugins/wp-widget-cache/inc/wcache.class.php on line 143

    Warning: fclose(): supplied argument is not a valid stream resource in /home/quick42/public_html/biblemoneymatters/wp-content/plugins/wp-widget-cache/inc/wcache.class.php on line 148

Viewing 11 replies - 1 through 11 (of 11 total)
  • Hi,

    I’m so sorry for this. The reason is you’re using php 4, and the
    function mkdir accept the 3rd param since php 5, I should have thought
    of this.

    I’ve just release a new version 0.25.1, please update.

    Regards,

    the new release fixed the problem. thanks.

    WP 2.6.3
    upgraded to 0.25.1
    PHP5 installed
    after plugin activation:

    WP Widget Cache not work!
    ‘/home/sbznstit/public_html/blog/wp-content/widget-cache’ cann’t be created

    NOTE: cache dir chmoded by me after plugin activation

    I have exactly the same problem like area97:

    WP 2.6.3
    upgraded to 0.25.1
    PHP5 installed
    after plugin activation:

    WP Widget Cache not work!
    ‘/home/sbznstit/public_html/blog/wp-content/widget-cache’ cann’t be created

    NOTE: cache dir chmoded 777 by me after plugin activation

    Looks like the automatic creation of the new folder /wp-content/widget-cache requires /wp-content to have chmod 777. This is obvious.

    @Plugin-Author: you should implement a better error-message so that your users get to know the exact cause for this problem, so they can fix it themselves by altering the the file-attributes of /wp-content.

    After I set /wp-content chmod 777, the plugin was able to create the new folder /wp-content/widget-cache. When it was created, I could reset /wp-content back to chmod 755.

    I mentioned above that my problem was fixed, and the original problem WAS fixed.

    Today I wrote a post and hit the save button from this page: http://www.yourwebsite.com/wp-admin/post.php?action=edit&post=1613

    Instead of saving as it normally does, today it refreshed to a blank Page:

    http://www.yourwebsite.com/wp-admin/post.php

    The same thing happens when i try to publish the post – it just goes to the blank page:

    http://www.yourwebsite.com/wp-admin/post.php
    I deactivated the widget cache plugin, and the save/publish features work again.

    Can you look into that and see why the plugin might be causing this problem?

    Hi Erunafailaro,

    You’re right, I should set more msg to tell the user what to do if there’s permission problems. I’ve updated the plugin files, but I would not update the plugin version, as it might not a good idea to push an update for such changes.

    Hi ande1352,

    I’ve no idea yet, but I’ll check the code asap.

    Regards,
    Andrew

    Hi,

    There’re alreay 3 people left me the message to tell having the same problem with ande1352, so it should be something wrong with my plugin. But I can’t replicate the error on my testing machine, 🙁

    I also found two related topic,

    http://wordpress.org/support/topic/154571?replies=47
    http://wordpress.org/support/topic/188747?replies=16

    tigtog

    (@tigtoggmailcom)

    Hi, I was having the same problem as well, Andrew, except only with pages, not posts. Deactivating the plug-in meant that I could write/change pages again. I just left a message on this topic stating that deactivating the WP Widget Cache plugin resolved the error.
    http://wordpress.org/support/topic/172300?replies=7#post-931270

    It’s not too much extra to deactivate the plugin before writing a page and then reactivating it, as pages don’t change *that* often, but as I’m using WP as a CMS on the site in question, updating information pages reasonably regularly, it is a *bit* of a PITA.

    Hello, Just encountered the same problem on WP 2.7…

    Was getting blank posts page, changed my server settings to exclusively PHP5 (from system default), post.php was no longer blank, but the widget plugin could no longer write its files/folders… The blank posts seemed to occur after I first set my expiration times in the widget menu.

    Problem I am having is with jQuery Lightbox (Balupton) see http://harrimanhikers.org – the page load lightning fast but when you try to enlarge one of the thumbnails – the white square of the sequence seems to be what was cached and is served.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Plugin: WP Widget Cache] Problem since .25 version of plugin’ is closed to new replies.