Support » Plugin: WP Video Posts » [Plugin: WP Video Posts] I have a converted file save problem

  • Resolved yok2504


    Hello first of all Thanks for the plug in this is very usefull thing.

    I was coding a script for this solution and see this plug in this is save my time.

    But I have a problem.

    I install plugin and ı try the .mov files to convert. Plugin make the screenshot thumbnail but converted .mp4 not saved the ftp side. first ı think its not 777 but not. Beacuse plugin can save screenshot.

    why it can happen to me. Why plug in make this error.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author cmstactics


    Hi Sinan. We tried reproducing your issue on our server with a sample .mov file and we didn’t have any issues. We sent you an email to assist you in solving your issue and after we help resolve your issue we can post the solution here for others to view.

    Alex Dodkin


    Hi Guys, I have the exact same problem as Sinan, can you give me the solution you found?


    Plugin Author AlexRayan


    Hi Alexdodkin,

    Yes, we solved the issue for Sinan but the issue was server specific. His FFMPEG installation was not full and was not properly configured (it was lacking encoding libraries and the path to the ffmpeg was different from that of a regular path).

    Please take a look at the installation guide I wrote here:

    Especially, make sure to check the manual to see what codecs are installed and supported by your ffmpeg installation.

    The version that is installed on our servers is usually FFmpeg version 0.6.5 with the following configuration:
    configuration: –prefix=/usr –enable-gpl –enable-libopencore-amrnb –enable-libopencore-amrwb –enable-libx264 –enable-version3 –enable-libfaac –enable-nonfree

    To check the codecs supported, type the following in command line:
    ffmpeg -codecs | less
    Make sure libfaac and libx264 are among the codecs available for you.

    You could also try to encode a test video from the command line to make sure that ffmpeg is working correctly:

    ffmpeg -y -i /path/to/source/file -acodec libfaac -vcodec libx264 -f mp4 -vtag avc1 -vpre normal -refs 1 -coder 1 -level 31 -threads 8 -partitions parti4x4+parti8x8+partp4x4+partp8x8+partb8x8 -flags +mv4 -trellis 1 -cmp 256 -me_range 16 -sc_threshold 40 -i_qfactor 0.71 -bf 0 -g 250 /path/to/new/file/to/save

    If all the flags don’t work for you it means something is not configured write in the ffmpeg installation. In this case you could also try to remove some of them and be left with:

    -acodec libfaac -vcodec libx264 -f mp4 -threads 8 -partitions parti4x4+parti8x8+partp4x4+partp8x8+partb8x8

    If you still have issues, feel free to email me at and I’ll do my best to help you.

    Best regards,

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: WP Video Posts] I have a converted file save problem’ is closed to new replies.