WordPress.org

Forums

[Plugin: WP-UserOnline] WP-Useronline break (29 posts)

  1. jayq
    Member
    Posted 5 years ago #

    Since the update to version 2.7, the variable %USERONLINE_COUNT% is issued instead of the value of the variable.
    to see in the admin area and in the widget on the page

    To see at: http://www.oberlahn-express.de

    ps.
    sorry for bad english - german folk :-)

  2. scribu
    Member
    Posted 5 years ago #

    Oups... replace it with %COUNT%.

  3. jayq
    Member
    Posted 5 years ago #

    Ähhh, and where? I use the Widget. Do you make a update of the PlugIn?

  4. scribu
    Member
    Posted 5 years ago #

    From the settings page.

    Anyway, fixed in version 2.71.

  5. vegidio
    Member
    Posted 5 years ago #

    Just installed 2.71 and it broke my Admin page of WordPress :-/
    Every time I try to access the admin area I see the error

    Fatal error: Call to undefined method scbOptions::get_key() in /wp-content/plugins/wp-useronline/admin.php on line 56

  6. vegidio
    Member
    Posted 5 years ago #

    Sorry, somehow my message was duplicated.

  7. petercasier
    Member
    Posted 5 years ago #

    @vegidio: I had the same problem. I deleted the plugin with FTP to be able to access my admin page again.

    Peter

  8. scribu
    Member
    Posted 5 years ago #

    @vegidio and @petercasier:

    1. Were you installing or upgrading the plugin?
    2. Did this also happen with version 2.70?
  9. vegidio
    Member
    Posted 5 years ago #

    @scribu

    I was upgrading from version 2.70 (installed yesterday night and worked fine) to version 2.71.

    My WordPress version is 2.9.2

  10. jayq
    Member
    Posted 5 years ago #

    @scribu - thanks now it works.
    V: 2.70 with WP 2.9.2

  11. petercasier
    Member
    Posted 5 years ago #

    @scribu
    I use wordpress 2.9.2 and was upgrading to the latest version of WP-Useronline

  12. Jinto
    Member
    Posted 5 years ago #

    i have tried deleting and renaming the folder and files and then get a missing file error....if you turn off all plugins via sql that fixes the issue just turn on the ones you want and remove the WP-UserOnline intill its fixed :/

  13. petercasier
    Member
    Posted 5 years ago #

    @Jinto,

    After deleting the plugin with FTP from my WP directory, I got the missing file error also, but upon detection, WP automatically disables the plugin, and the site works well again (without the plugin of course)

    Peter

  14. evanw
    Member
    Posted 5 years ago #

    I also was unable to access wp-admin after upgrading this plugin, received a fatal error with one of the UserOnline files. Had to delete the plugin to get back into the admin interface.

  15. kinderr
    Member
    Posted 5 years ago #

    The 2.71 automatic upgrade fails and crashes wp-admin with the error:

    Fatal error: Call to undefined method scbOptions::get_key() in /home4/handyma5/public_html/wp-content/plugins/wp-useronline/admin.php on line 56

    I had to log into cPanel on BlueHost.com and rename the plugin directory to access wp-admin.

    Running WP 2.9.2

  16. kinderr
    Member
    Posted 5 years ago #

    Update:

    After disabling the 2.71 upgrade by renaming the plugin directory via FileManager in CPanel, I changed the name back to the original in preparation for deleting the plugin and all files.

    Just for kicks, I re-activated the 2.71 plugin and it works fine! Can access wp-admin (Site Admin) OK now.

  17. vegidio
    Member
    Posted 5 years ago #

    @kinderr:

    Didn't work for me. I re-activated the plugin but the Admin page is still broken. Strangely, the plugin seems to be working fine when I'm accessing any other page. I can see the number of users online through the widget.

  18. scribu
    Member
    Posted 5 years ago #

    @petercasier and @Jinto: Can you post the missing file path?

    @kinderr and @vegidio: Do you have any other plugins of mine active?

  19. petercasier
    Member
    Posted 5 years ago #

    @scribu:
    confusion -- the missing file error only occurs -rightfully- after I delete the wp-useronline plugin directly. so that is not an error per se.

    The key problem is:

    Fatal error: Call to undefined method scbOptions::get_key() in /wp-content/plugins/wp-useronline/admin.php on line 56

  20. vegidio
    Member
    Posted 5 years ago #

    @scribu:

    Here is the full list of plugins that I use, including 4 created by you and/or Lester: http://i.imgur.com/T2b2J.png

  21. scribu
    Member
    Posted 5 years ago #

    Thanks everyone for the feedback. I'll release a fix soon.

  22. maitremo
    Member
    Posted 5 years ago #

    Hi,

    I've just uploaded 2.71, and no error message, but the plugin doesn't works anymore : the widget and the dashborad say that there is no people on line...
    I think there was before a "useronline" table on my database, but it's no more there, I suppose the problem is this one..?
    Unfortunately, it's also means that I can't reinstall the older files...
    Thank you if you can fix that !

  23. scribu
    Member
    Posted 5 years ago #

    See if it still happens with version 2.72.

  24. kinderr
    Member
    Posted 5 years ago #

    > @kinderr and @vegidio: Do you have any other plugins of mine active?

    I also use the WP-PageNavi plugin.

  25. petercasier
    Member
    Posted 5 years ago #

    @scribu:
    Indeed version 2.72 of the plug-in solved the problem of Fatal error: Call to undefined method scbOptions::get_key() in /wp-content/plugins/wp-useronline/admin.php on line 56

    THANKS!

  26. scribu
    Member
    Posted 5 years ago #

    Try installing the development versions of both plugins:

    WP-PageNavi (2.73-alpha).

    WP-UserOnline (2.73-alpha).

  27. maitremo
    Member
    Posted 5 years ago #

    OK, same problem for me with 2.72 and 2.73-alpha : no errors, but "0 users online now", on widget and admin...
    I thought it was a problem of database, but it's not : it still displays the "most users ever on line"...
    I don't know what to do...
    Thanks for your help !

  28. Anonymous
    Unregistered
    Posted 5 years ago #

    I just installed WP-UserOnline version 2.72
    ( my usage is simple, i only want to see the info in my admin page)

    and I have the same problem as MaitreMo ( only show 0 Users online )

    There are a total of 0 Users online now: 0 Members, 0 Guests and 0 Bots.
    Most users ever online were 1, on May 9, 2010 @ 9:28 pm

    not sure if it's relevant but I have Frontend Editor installed.

  29. scribu
    Member
    Posted 5 years ago #

Topic Closed

This topic has been closed to new replies.

About this Topic