Support » Plugins and Hacks » [Plugin: WP-UserOnline] New version broken

  • I just updated wp-online (which was working perfectly before) via the auto update in wordpress plugin page.
    However, it did not seem to create the database in my sql and am getting database table wp_useronline doesn’t exit errors.

    I could create it manually but that defeats the object of you writing code to do it and it’s a bit fiddly with MySQL administrator.

    PS. While I am writing I also found with the previous version I needed to change the type of useragent in the CREATE TABLE to ‘text’ instead of ‘varchar’ as there are some useragents that have more than 255 characters!

    http://wordpress.org/extend/plugins/wp-useronline/

Viewing 15 replies - 1 through 15 (of 16 total)
  • You probably had an error at activation. See if it happens with version 2.72.

    Marcos

    (@marcos-blatt)

    Hi ‘scribu’,

    your plugin is very useful but when I’ve upgraded it to version 2.71 occurred a fatal error and I could not enter my admin page.

    Now, with version 2.72, at the moment of activation, occurs another fatal error as you can see in this screen shot (http://tinyurl.com/24fvce2).

    After that the plugin seems to work but with a lot of errors (including settings page) and I had to deactivate it.

    I hope you next fix. :o)

    Thanks a lot!

    Did the WP dashboard automatic upgrade from 2.71 (which originally failed) to 2.72 and got a “fatal error” message with no other details.

    Running WP 2.9.2.

    @marcos Blatt: try reactivating it.

    Marcos

    (@marcos-blatt)

    Hi ‘scribu’,

    I’ve done you’ve suggested but it still in the same way.
    No problem, I’m gonna wait for a stable version (not alpha or beta).

    You’re doing a good work, anyway. Good luck!!!

    Marcos

    (@marcos-blatt)

    Hi ‘scribu’,

    I’ve updated the plugin to version 2.73 and it seems to work almost(…) fine.
    There are still some errors as you can see in this image.

    You’re closed to fix it. Good luck! :o)

    Check the time format in Settings -> General.

    Marcos

    (@marcos-blatt)

    OK, buddy! It’s all working well now.
    My time settings were personalized in the wrong way.
    My blog is still under construction and I’ve forgotten some minor adjustments.

    Thank you very, very much and GOOD LUCK!

    Nope!
    Database still not creating on automatic update and activation in v2.73!

    Getting:
    WordPress database error: [Table ‘jimtestwp.wp_useronline’ doesn’t exist]
    on homepage!

    Same problem here, database is not created. Has been working correctly until recently. Have just installed 2.73. Have tried to return date format to default and also to reactivate several times, but no success. Getting the following error:

    WordPress database error Table ‘blog.wp_useronline’ doesn’t exist for query SELECT * FROM wp_useronline made by require, require_once, include, get_footer, locate_template, load_template, require_once, suffusion_before_end_container, do_action, call_user_func_array, suffusion_print_right_sidebars, get_sidebar, locate_template, load_template, require_once, dynamic_sidebar, call_user_func_array, WP_Widget->display_callback, scbWidget->widget, UserOnline_Widget->content, get_users_browsing_site, UserOnline_Template->compact_list, referer: http://www.viajeros.dyndns.info/blog/wp-admin/plugins.php?activate=true&plugin_status=recent&paged=1

    Please help.

    @sleepuser and @manutremo: sorry, but I really can’t help you guys unless I see what’s happening with my own eyes. I will need an admin account on your site for that.

    Alternatively, you can go back to the 2.62 version.

    The new version of the plugin stopped working for some reason. I didn’t get any errors, but it always showed 0 users online, even when I knew from a different plugin that there were 5 or more. I deactivated and reactivated and it seems to be working again.

    Great plug, thanks.

    @jmacofearth

    The Time Out setting no longer works. It won’t accept numbers that are too large. For example, 72,000 gets saved as 72. 36,000 takes, but the users remain in the database far shorter, more like 3 hours.

    There are also 9 bots named Baidu that seem to persist. I never had that before.

    I’ve used this plug-in on several sites, but now I’m doubting it’s accuracy. I will go back to a previous version because I really do like your plug-in.

    Thanks for all the work you’ve put into it.

    The Baidu bots seem to persist because they actually do make a lot of hits. You didn’t notice them before because they weren’t marked as bots.

    As for the large number problem, try leaving out the comma: 72000

    Hi scribu. I read all the topic, I tried all the solution, but to me are always zero users online.

    I tried every version of the plugin but after the upgrade to WP 2.9.2 the plugin stopped working.

    I also noticed that the wp_useronline table is not created.

    My version of MySQL is: MySQL: 5.0.82sp1-log

    I also tried to create manually the table as written here: http://forums.lesterchan.net/index.php/topic,3011.0.html.

    but nothing.

    Any help? Thank you.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Plugin: WP-UserOnline] New version broken’ is closed to new replies.