Support » Plugins and Hacks » [Plugin: WP-UserLogin] Possible glitch

Viewing 15 replies - 1 through 15 (of 17 total)
  • Looks like the author doesn’t visit this forum much…

    Gene

    Sorry for not getting back to this sooner. I took care of the problem, but didn’t see this post (I’ve been out of the house for the past few days). Anyway, the problem has been fixed. As soon as WordPress catches up with the repositories v2.1 should be available. Thanks for letting me know about this.

    Hi,

    Anyway, the problem has been fixed.

    Thanks, I downloaded and installed it and it works fine.

    Mind you, I had something similar (but crude) working by inserting the following code in a Daiko’s Text Box:

    <?php
      global $user_ID, $user_identity;
      get_currentuserinfo();
      if (!$user_ID):
    ?>
    	      <form name="loginform" id="autoriz" action="<?php echo get_settings('siteurl'); ?>/wp-login.php" method="post">
    	        <h2>Member Login</h2>
    	        <label for="login">Login:</label>
    	        <input type="text" name="log" value="" id="login" /><br />
    	        <label for="password">Password:</label>
    	        <input type="password" name="pwd" value="" id="password" />
    	        <input type="hidden" name="rememberme" value="forever" />
    	        <input type="submit" name="submit" value="Login" id="enter" />
    	        <input type="hidden" name="redirect_to" value="<?php echo $_SERVER['REQUEST_URI']; ?>" />
    	        <p><?php wp_register('', ''); ?>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;<a href="<?php bloginfo('wpurl'); ?>/wp-login.php?action=lostpassword">Lost your password?</a></p>
    	      </form>
    <?php else: ?>
    	      <div id="manage">
    	        <h2>Member Functions</h2>
    	        <p>Hi, <?php echo $user_identity; ?>!</p>
    	        <ul>
                <li><a href="<?php bloginfo('url'); ?>/wp-admin/post-new.php">Write Article</a></li>
    <?php if (current_user_can('level_10')){ ?>
    			<li><a href="<?php bloginfo('url'); ?>/wp-admin/">Dashboard</a></li>
                <li><a href="<?php bloginfo('url'); ?>/wp-admin/edit.php">Manage Posts</a></li>
                <li><a href="<?php bloginfo('url'); ?>/wp-admin/edit-comments.php">Manage Comments</a></li>
    <?php }?>
    <?php if (!current_user_can('level_10')){ ?>
                <li><a href="<?php bloginfo('url'); ?>/wp-admin/profile.php">My Profile</a></li>
    <?php }?>
    	          <li><a href="<?php echo get_settings('siteurl') . '/wp-login.php?action=logout&amp;redirect_to=' . $_SERVER['REQUEST_URI']; ?>">Logout</a></li>
    	        </ul>
    	      </div>
    <?php endif; ?>

    I like the option to go directly to “moderate comments”, if this were possible.

    Cheers,
    Gene

    Oops, think I found a bug, when clicking on “register”, I get a 404 page on account that it doesn’t take into account the sub-folder WP is installed in (http://yoursite.com/wp-login.php?action=register instead of http://yoursite.com/blogfolder/wp-login.php?action=register).

    Cheers,
    Gene

    I know where the problem is, I think. I’ll have a new revision up by morning (currently 19:35 California Time). Thanks for keeping me on my toes. 🙂

    I know where the problem is, I think. I’ll have a new revision up by morning. Thanks for keeping me on my toes. 🙂

    LOL, love testing plugins, glad you fixed it.

    Cheers,
    Gene

    I think this would be a great plug-in but I am getting an error.

    Please see in the upper right of my site:

    http://dev.piermarketing.com/sd/

    Any ideas?

    I’m not seeing any errors on your site. Care to explain the error to me? What version of the plugin are you using?

    Leftville, I get:

    Warning: implode() [function.implode]: Invalid arguments passed in C:\xampp\htdocs\wordpress\wp-content\plugins\wp-userlogin\userlogin_widget.php on line 124

    any solution?
    Michael

    I’ve been gone for a while due to a huge move. Let me take a look at the code and see what might be causing the problem. Then I’ll get back to you. Thanks for being so patient.

    Hi leftville,

    It seems that I got the same problem :

    Warning: implode() [function.implode]: Bad arguments. in C:\xyzxyz\wp-content\plugins\wp-userlogin\userlogin_widget.php on line 124

    I’m on version 2.6.2 and the error appears only when the user is logged in. When he is off, fields and links are displayed correctly.

    Thanks for bringing your support, your plugin is very useful.

    da.gray

    I can’t seem to reproduce the errors you guys have given me on my local systems (Windows, Mac, or Linux). Perhaps reinstalling the plugin might help, there’s the slim chance that you may have gotten hold of the mid-fix revision that accidentally got uploaded as 2.2 some time ago. Other than that, I’ll definitely keep looking into this issue.

    Hi Leftville and thanks for reply.

    I don’t know why, but I’m not able to reproduce the error too. All is running with no error when the user is logged.
    Apparently, it seems that concerns only the first log. When surfing on other pages and coming back to home, the error seems not exist anymore…

    I tried to create a new member, logged in with new codes, and there wasn’t any error.

    Finally figured it out. If the Login and Control Panel title fields are left blank you will get the resulting implode error. I’ll work on fixing this in later releases.

    Hi. I’ve got the same error too but on a diff line:
    implode() [function.implode]: Invalid arguments passed in C:\SVdP\wordpress\wp-content\plugins\wp-userlogin\userlogin_widget.php on line 129

    On a localhost version of WP 2.7. Setting User Login from the selection of Widgets, gives me this error either with data in the User Form Title and Control Panel Title fields or if those fields are left blank. Wish I knew what those labels meant and where I should expect to see them.

    Nonetheless, this nice plugin is busted for me until repaired or a workaround appears.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Plugin: WP-UserLogin] Possible glitch’ is closed to new replies.