WordPress.org

Forums

WP User Frontend
Great plugin! Problems with categories though... (9 posts)

  1. stl99
    Member
    Posted 3 years ago #

    Hello Tareq,

    First I want to thank you for this great plugin! I tried to do something similar with several paid plugins but it never worked out...

    Everything works fine except that I can't submit a new post on the new post page. Every time I push submit post the category dropdown field gets marked red although I have a category selected. Also subcategories aren't displayed in the dropdown. I have all other plugins deactivated, any idea what could cause this?

    And concerning the custom taxonomies - how do I make them work? Just adding the slug of an existing custom taxonomy under the plugin's admin taxonomy section and then it gets displayed in the dropdown?

    Many thanks in advance for your help!

    Regards,
    Thomas

    http://wordpress.org/extend/plugins/wp-user-frontend/

  2. Tareq Hasan
    Member
    Plugin Author

    Posted 3 years ago #

    Hello Thomas,

    I am not sure about the first problem you are facing. I've never heard anything like that :S

    And sorry, the custom taxonomies are not implemented fully. They are not effective in the frontend yet. I am so busy to that can't manage time to implement that.

    Thanks

  3. cabaj
    Member
    Posted 3 years ago #

    Hi Tareq,

    A very powerful plugin - well done.
    I'm one of many that need users to be able to assign a term from a custom taxonomy to their post.

    If and when you are able to implement that feature, you can expect a larger than average donation from me!

  4. WAXFROGDESIGN
    Member
    Posted 3 years ago #

    I have implemented custom taxonomy to the plugin. If you're interested contact me on [ email redacted ]

  5. Can Oezbay
    Member
    Posted 3 years ago #

    Hello Tareq! First of all, thank you so much for this amazing plugin. It's a life-saving game changer. However I have the same problem with stl99. Every time I push submit post the category dropdown field gets marked red although I have a category selected.

    I'm also trying to figure out what's causing this problem. I'll let you know if I can find out.

  6. WAXFROGDESIGN
    Member
    Posted 3 years ago #

    It's a jquery validation problem.

    Have you changed anything in the main plugin files CANOZBAY?

  7. Can Oezbay
    Member
    Posted 3 years ago #

    No. I haven't changed anything in the category validation. Except this :

    //validate cat
    if ( $cat == '-1' ) {
    $errors[] = __( 'Please select a class', 'wpuf' );
    }

    and I don't think it should cause any problems?

  8. roje0913
    Member
    Posted 3 years ago #

    waxfrogdesign, I have just emailed you, please shoot me the custom taxonomy addition to this plugin. Thanks!!

  9. MarceFX
    Member
    Posted 2 years ago #

    Any news on this?
    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP User Frontend
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic