Support » Plugin: WP Ultimate Search » [Plugin: WP Ultimate Search] Tag search is not working

Viewing 15 replies - 1 through 15 (of 18 total)
  • The version we’re working on actually supports unlimited custom taxonomies, including tags. We’re planning at some point to fork this plugin into a premium and a basic version, and so we’re taking this opportunity to decide which features should be in which version.

    So, the version that I can download from wordpress.com doesn’t have those futures. After you’ll include them will be a great plugin.

    Thought I’d give you a heads up… the new version has just been released. You should see the update appear in your dashboard soon. If you have any questions or problems, you can contact us here, or through our support site at http://mindsharelabs.com/

    Thanks for your interest and support!

    I just installed the free version on a site I am currently developing, and also cannot get the Tags option to show any results when searching. Categories works fine. Everything is up to date on the site, and this plugin is installed with all default settings.

    Any known issues that I can try to resolve this with?

    Try switching to the default theme and disabling all other plugins to see if there is a conflict.

    Or, you can create an account for us on your site (bryce@mindsharestudios.com) and we’ll log in and take a look.

    I am also having a problem with the “tags” search. They populate correctly, but when selected nothing happens. The “categories” search works fine.

    Somewhat related: will there be a way to change the name of the Categories and Tags taxonomies? For example if I wanted to make it say “Topic” instead of “Category”?

    Are there posts with the tags in question applied? Try creating a post with several tags applied and see if it appears. As above, try disabling all other plugins (especially anything that messes with custom taxonomies) and try again.

    The premium version supports this now. We’ll be adding support to change the name of “Category” and “Tag” to the free version in a future release.

    Yes, there are. Nothing happens when a tag is chosen.

    I tried the plugin out on a test site (with no other plugins active) and it still wouldn’t provide any results for tags.

    Great to hear about the names!

    Could you create a user account for me on your site, so I can try it out myself? My email is bryce@mindsharestudios.com.

    Okay, I created a new user on the development site. You should be receiving an email about it.

    Thanks for setting that up. I just took a look, tried a few things out, and I really have no idea why it’s not working… especially with categories working fine. I looked directly at the results from the database query and for both tags the database says that there are no posts.

    Is it possible that maybe you’ve registered another taxonomy at some point that could be conflicting with the way tags are handled? Is it possible that part of your setup is in another language, or uses special characters?

    Sorry I couldn’t be of more help

    I don’t think there is another taxonomy. It’s possible that there might be Hebrew somewhere, but definitely not in the tags and I really don’t think that there is.

    Are others having similar problems?

    Never encountered this problem before, that’s the weird part. Have you tried switching back to the default theme, disabling other plugins, etc etc?

    My experience since my earlier post has been that any 3rd party theme that incorporates its own built-in search code can in some way break all 3rd party search plugins by different developers (I’ve tried at least 5 of the most popular ones and NONE worked properly). So unless you stick to the default WordPress [crappy/bland] themes, you’ll have to stick with WordPress’ crappy search, OR the search code implemented in your 3rd party theme.

    I was using themes with Rockettheme’s Gantry framework. It broke a LOT of stuff including all search plugins. Lame. I can’t fix their bloated code. The Jetpack plugin also hates Gantry, to name another incompatibility…

    I’m ditching WordPress for Squarespace. This issue is one of many factors that started the switching process for me, since it helped me discover the many shortcomings of plugin and theme compatibility common to WordPress and other open source ecosystems.

    Ditching crappy/cheap shared hosting is my other main reason for choosing Squarespace. Dreamhost has been very lame this past year and I’m sick of waiting for them to get their act together. You get what you pay for… Sorry I got off topic.

    Good luck to you all! Thanks for the effort Bryce! I don’t envy you! Looks like a great plugin when paired with other plugins and themes that play nice…

    Are others having similar problems?

    And yes, bludrop. What you are experiencing is exactly what was happening to my site. No tags, just categories showing. No taxonomies set up at all.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[Plugin: WP Ultimate Search] Tag search is not working’ is closed to new replies.