WordPress.org

Forums

WP UI - Tabs, Accordions, Sliders
[resolved] Add Media Button Not Working (18 posts)

  1. Nir
    Member
    Posted 3 years ago #

    Hi There,

    I've installed WP-UI and it works fine.

    However, in a Page/Post edit page, the add media button does not work. Also I noticed that the menus of the left sidebar (wordpress backend - e.g. dashboard / settings / appearance / etc.) do not work either (do not get opened).

    When deactivating the plugin, everything works just fine.

    What might cause this problem ? is it JS related ?

    Thanks a lot in advance,

    Nir

    http://wordpress.org/extend/plugins/wp-ui/

  2. kavingray
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Nir,

    This might be a JS conflict. Not directly from the plugin, but result of conflicting code in two plugins. First, please make sure you have the current version 0.8.1, and the other plugins are up2date.

    Only way to find out is deactivating possible plugins temporarily and check again. Or It might also be the browser cache problem. Please inform me of any plugin conflict found, that will be correctly promptly.

    Thanks :)

  3. Corbula
    Member
    Posted 3 years ago #

    The same thing is happening to me.

    I tried disabling all other plugins and just leaving WP UI active and i still have the problem.

    The featured image overlay doesn't work, you just get redirected to another page, the media upload buttons don't work and the collapse expand on the left dashboard menu doesn't work.

    I'm using wordpress 3.2.1 and the latest version of WP UI. I think it is to do with the last update to the plugin but not sure.

  4. kavingray
    Member
    Plugin Author

    Posted 3 years ago #

    Hi there,

    I checked again with WP 3.2.1 and was unfortunately not able to reproduce the issue with both the media upload buttons and the featured image. Did you save the plugin's options after update?

    Sometimes this might be related to browser's cache ( most notably safari/chrome). If you are using any Cache plugins on WP, please make sure you have emptied the cache.

  5. Corbula
    Member
    Posted 3 years ago #

    Thanks for the reply.

    I've updated the plugin to it's latest version but it's still happening. I tried saving the options but that didn't work.

    I'm using firefox but tried in IE and it's the same. I'm using WP Super Cache but it's still happening when all of the plugins except WP UI are deactivated. If i leave all of the plugins active and just disable WP UI it still happens.

    Under General options the only thing i have active is Tabs.
    Under style I have load multiple CSS3 styles checked.
    Under advanced the only thing active is Blank Page fix.

    I really need to get to the bottom of this as it breaks the featured image, file upload field and the media upload buttons.

  6. kavingray
    Member
    Plugin Author

    Posted 3 years ago #

    Maybe it's a conflict with the theme. Sorry about the issues, It's unlikely the problem to occur with all the modal windows that use thickbox. There used to be a problem with versions =< 0.7.5, But those were all fixed in the current version. Now thickbox is only used in the inline docs, that i believe hardly would cause such a conflict.

    BTW, may i know what you mean by "If i leave all of the plugins active and just disable WP UI it still happens.". If that's correct, then it can't be something related to the plugin?

  7. Corbula
    Member
    Posted 3 years ago #

    Sorry typo, i knew in my head what i was trying to say.

    If all plugins are active and i disable WP UI it doesn't happen.

  8. kavingray
    Member
    Plugin Author

    Posted 3 years ago #

    Sorry about the issues, But we can't figure this out by going in blindly, as this might be an inter plugin/code conflict i.e. Conflicting code that might be present in another plugins( or theme). We need to find out whichever is triggering this issue.

    I tried multiple times in the following setups - WP 3.2.1 & 3.3.1 both on Regular & Network individually, without luck.

    Is it possible to list the plugins & theme that are activated currently?

  9. vagdesign
    Member
    Posted 3 years ago #

    Since yesterday I'm experiencing a similar problem.
    All the tabs display the content but the script to display the tabs, sliders, accordions doesn't appear.

    You can have a look to this website and check for yourself:
    http://www.texnopolispark.gr/site/

    As you'll see on the lower part of the page, there are 4 UI widgets.
    None of them is loaded, still the content appears.
    This happened without changing anything on the WP or to the content.

    I believe this might be a problem with .js

    Can you help me on this?
    Thanks in advance,
    Vangelis.

  10. kavingray
    Member
    Plugin Author

    Posted 3 years ago #

    Hi @vagdesign, this issue is totally unrelated to the problem @corbula is experiencing. That's related to the admin screen.

    And I checked the site - There appears to be jQuery 1.2.6, very olr version of jQuery being loaded by image-gallery-with-slideshow plugin. WP UI needs jQuery 1.4 or greater to work and uses jQuery 1.7.1, loaded by WordPress as default.

    Please update/deactivate the plugin, whichever is applicable.

    Regards,
    Kavin

  11. vagdesign
    Member
    Posted 3 years ago #

    Hello Kavin,
    You were right, disabling the plugin made the problem disappear.

    Thanks for you time and for this great plugin.
    Best regards,
    Vangelis.

  12. Corbula
    Member
    Posted 3 years ago #

    The theme is called Ultra by wpexplorer.

    Here's a list of the plugins i'm using:
    add-descendants-as-submenu-items
    adminimize
    advanced-custom-fields
    cimy-user-extra-fields
    collapsing-archives
    collapsing-categories
    collapsing-pages
    contact-form-7
    contact-form-7-dynamic-text-extension
    contact-form-7-to-database-extension
    display-posts-shortcode
    download-monitor
    members
    more-taxonomies
    more-types
    peters-login-redirect
    related-posts-thumbnails
    relevanssi
    taxonomy-images
    tinymce-advanced
    wordpress-seo
    wp-minify
    wp-super-cache
    wp-ui
    zingiri-tickets

  13. kavingray
    Member
    Plugin Author

    Posted 3 years ago #

    @corbula - Thanks for the list. Tried almost everything without success.

    Please uncheck the "TinyMCE menu" and HTML Editor buttons on Options page and see if the issue resolves.

    BTW, did you empty the cache( WP Super cache's) after updating the plugin?

  14. Corbula
    Member
    Posted 3 years ago #

    Those options were already unchecked.

    and yes i've cleared the cached.

  15. kavingray
    Member
    Plugin Author

    Posted 3 years ago #

    Sorry buddy - I hoped that would solve something. I cannot figure out this problem by going in blindly, since this occurs in the admin screen.

    Are you getting any errors in the Firebug/chrome-inspector console?

  16. Corbula
    Member
    Posted 3 years ago #

    Thank you. I think i have fixed it now.

    I was getting an error and it was because i had some code in my functions.php so it would use google ajax libraries to call jquery. (it's supposed to make the site quicker if it's already loaded from google). It's basically the same as the Use Google Libraries plugin.

    I've removed that from my functions.php file and it seems to have worked.

  17. justabloke7676
    Member
    Posted 2 years ago #

    Hi Kavin,

    First, your website is down. Hope you can get it up and going again. I'm sure there is good information for using your plugin.

    Also, I've created a new jquery theme, uploaded it and it works great! I love the fact we can customize the colors. There is a slight problem however. There seems to be a conflict with my theme. I use Headway and if I use the jquery custom theme (style tab), it will break the visual editor (blocks move). If I use one of the UI styles (not jquery) everything works perfectly fine. I don't mind keeping it here to set up my site then changing it to the custom theme when it goes live, but it would of course be great if this conflict could be resolved. Any ideas?

    Thanks.

    Wonderful plugin!

  18. dorearendil
    Member
    Posted 2 years ago #

    Guys, is Kavin still active anywhere?
    His website is down, and it's been so for a long time.

    The tabs from his plug-in don't work at all on my site (see http://www.meridian-online.com/tabtest3). I suspect a .js problem, especially since they don't work with other similar plug-ins I've installed recently:

    Would anyone know how I could solve this issue? Could it be that my theme is also loading an old version of jQuery, like a previous poster in this thread? How can I verify this?

    Cheers,
    Dorian

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP UI - Tabs, Accordions, Sliders
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags