Support » Plugin: wp-Typography » [Plugin: wp-Typography] Plugin corrupting unicode characters, can't uninstall

  • Hi there,

    This plugin is a very neat idea. I’ve had problems with it, though:

    When I installed, unicode characters already existing in my pages, such as “, ”, —, etc. immediately became corrupt.

    Deactivating, and even deleting the plugin files completely, haven’t fixed the problem. What can we do?

    You can see what it looks like here:

    Original text in HTML view:


    and so on it went—tonset


    emdash — dash “smart quotes”

    Resulting text when I preview or view page:


    and so on it went—tonset


    emdash — dash “smart quotes”

    Isn’t it interesting that — gets turned into — even after the plugin is deleted? If the plugin is activated, I can turn that option off, but it shouldn’t keep happening when the plugin is removed entirely. Any ideas?

    As a side note, an uninstall routine would be great. It seems like filters are being cached here (I didn’t even know that was possible!), but I don’t have any caching plugins activated.

    FYI: We run on a multisite installation. This is the main (first) site in the network. I’m using the latest version of wp-typography as of yesterday.

    Thanks for any help.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Sorry to hear that. I looked at the description of the plugin, and it mentions “intelligent character replacement”. Unfortunately, to me, this means that the actual data may be changed. In that case, an uninstall may not restore the original data.

    So you’re probably in for a lot of manual text repair. Unless there’s some function in the plugin that will re-convert the text somehow.

    Good luck.

    What I find interesting is that in the back-end — the Edit Page screen — everything looks like it should. So I don’t think any content changes have actually been made. (Phew! 🙂 )

    “Intelligent” means that is replaces characters intelligently — taking into account things like context, etc.

    Yeah, I feel some of your pain. I’m very leery of using anything that does a mass conversion of anything. I guess this one didn’t work so intelligently.

    I also wonder if somewhere along the line, maybe your database was not UTF-8, and the app was expecting that, or some similar issue. The vagaries of character sets get pretty gnarly, and I don’t understand them that well. The closest I come is having memorized a bunch of common entities so that I can get validated XHTML.

    If I were doing this repair, being a geek, I would use PHPMyAdmin to run SQL mass queries to “change all” for any offending string (after backing up my tables first, in case I screw up). I’ve rescued a number of sites this way. MUCH faster than manual editing, but somewhat scary if you’ve never done this before.

    I also shake my head to see how often any Cufon-related theme will break any non-English text. If I were doing any non-English language, I wouldn’t touch that thing with a 10-foot pole. But at least that’s not altering the data itself.

    Thanks for your sympathy. 🙂

    And, an epilogue: the problem is gone, though I don’t know what fixed it.

    The unexpected behavior of — turning into a em-dash (something that this plugin did) is still there, but unicode characters I put in myself are no longer being corrupted.

    All’s well that ends well. I guess I can move on.


    The plugin does not make any changes to the stored content. It filter’s it on the fly, and is 100% reversible by deactivating the plugin. If your content is still changed after deactivation, it is not this plugin that is causing that – although it could be a cached version of the page this plugin created. If you are using a caching plugin, try flushing the cache.

    Jeffrey, thanks for your response, and thanks for putting your energy into this plugin. I wasn’t using a caching plugin, but something goofy along those lines must have been happening. In any case, it works now. I hope to come back and try it again in the future.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Plugin: wp-Typography] Plugin corrupting unicode characters, can't uninstall’ is closed to new replies.