Support » Plugins » [Plugin: wp-Typography] Disappearing Text?

  • I’m the plugin author.

    I’ve seen two reports on twitter of disappearing text related to the wp-Typography plugin with version 1.21.1 and wp version 2.9.2. The posters have not responded with information that has allowed me to recreate the issue. I do not know if it is a theme deficiency, or a plugin bug.

    Is anyone else having this issue? If so, can you tip me off on how to recreate it? If there is a bug in the plugin, I’d like to fix it.


Viewing 11 replies - 1 through 11 (of 11 total)
  • I have access to a 2.9.2 installation manifesting an issue possibly fitting your description, with two different themes: the default theme (Kubrick) and Comet. We have yet to isolate any specific conditions that trigger the issue; everything works until wp-Typography is activated, after which all posts and titles are shown on the blog as if they had been erased (empty contents). The content can still be read and edited on the admin side, though. We’ve tried uninstalling and re-installing the plugin, even going as far as clearing the options from WP’s database in between, to no avail.

    I do have another installation of WPMU running on a different host, and there wp-Typography works just fine, so the difference may lie in server configurations. Here’s the PHP configuration for the latter (working) installation. The problematic installation is on an as-of-yet unreleased site, so here’s a copy its configuration I stored on the working server.

    You’re welcome to suggest any tests we can try, although I have to say that unless other major problems occur, the site probably goes live within a couple of weeks and obviously any testing has to be done prior to that.


    It looks like you have properly installed the mb_string extension on both servers. I notice the working server lists the db encoding as UTF-8, but the errant configuration does not list the db encoding. Is your db encoded UTF-8? Are your WordPress installs similarly encoded UTF-8?


    The db is UTF-8 encoded according to phpMyAdmin:

    `MySQL charset: UTF-8 Unicode (utf8)
    MySQL connection collation: utf8_unicode_ci`

    Both installs define DB_CHARSET as utf8 in wp-config.php, DB_COLLATE is left at default (blank).

    Anything more you need to know, just ask.


    Everything else looks as I’d expect. The only other issue I could think of is perhaps it is not a server issue, but a plugin conflict. Have you tried disabling your other plugins? I know there are conflicts with Kimili Flash Embed, but that has to do with his method of using shortcodes. It shouldn’t make content disappear.

    Otherwise, I am at a loss.


    Akismet was the only other plugin enabled with wp-Typo, so conflicts there shouldn’t be an issue. Funnily, I’m using Kimili Flash Embed in the other, working installation, and haven’t come across any issues there, although this might be more due to the little use I have for Flash.

    My hunch is that it still has to do with encodings, because the working setup’s server defaults to UTF-8 while the non-working one’s ISO-8859-15 has to be overridden with a “AddDefaultCharset UTF-8” in .htaccess. But after this, the headers and everything else seems to work as if the setup truly was UTF-8, so I can’t see which component still might think it’s not.

    Anyway, the site has been released now, without wp-Typography at least for the time being. Feel free to poke the headers or anything you like with the site at — though it’s probably tough to navigate, unless you know Finnish. 🙂

    Hi there, I’m experiencing this issue as well. I’m running my site on WP 2.9.1 and the latest version of wp-Typography.

    Encoding is set to UTF-8 on both the DB and WP. Tried disabling other plugins to no avail.

    Anything else I could try to help figure out this issue?


    Ok, I tried disabling a couple of things in the settings for the plugin, and it looks like disabling “Wrap acronyms (all capitals) with…” does the trick.

    Something to do with reg expressions I’m sure.

    Thanks, droppyale! Disabling acronym wrap worked for me as well. If I enable it, my site prints out the following warning:

    Warning: preg_replace() [function.preg-replace]: Compilation failed: support for \P, \p, and \X has not been compiled at offset 163 in /[…]/wp-content/plugins/wp-typography/php-typography/php-typography.php on line 1909

    I hope that is of some help in the bug hunt.

    droppyale and janneuu. I think I have resolved the issue in the current development version of the plugin (which will be released as version 1.23). Before I push the update, could you test the development version at and let me know if you are able to enable wrapping acronyms without errors on your sites? You can email me at jeff at kingdesk dot com. Thanks.

    The fix for this is now live in version 2.0

    I updated the plugin and can now enable acronym wrap without problems. Many thanks!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Plugin: wp-Typography] Disappearing Text?’ is closed to new replies.