WordPress.org

Support

Support » Plugins and Hacks » [Plugin: WP Tuner] What is running Slow?

[Plugin: WP Tuner] What is running Slow?

  • I have activated wptuner, and I can not see that plugins are taking a long time:

    The start and post selection seem to be taking the longest time, is that due to a large database over 100mb?

    0 Start 1,494.6
    1 plugins_loaded 13.7
    2 widgets_init 7.0
    3 init 99.1
    4 posts_selection 762.5

    I have had the mysql went away error a few times as well

Viewing 4 replies - 1 through 4 (of 4 total)
  • I just added some more code in wpsettings.php and can see that Before the plugins even load Start takes 347ms isn’t this a bit long?

    How is that your database is 100 Megs? Thats huge! Did you ever check for overhead in your SQL? I think some PHP sql Table optimization may help you.

    (Sorry for the delayed response! Most people ask questions in our blog…)

    Your “start” time includes everything up until the plugins are fully loaded. So that means plugin load time could easily be the culprit.

    347ms before plugins start to load is a bit long but perhaps not so bad on your server. It all depends…

    However: 762ms for Posts selection is rather a lot. Do you have a ton of posts by any chance? If so, you may need to do some careful optimization, as Chaos Inc suggested 🙂

    To examine this in more detail requires some WP code changes that can’t be done automagically by WP Tuner. For further hints, look at the wptuner page, in the “other notes” area. I’ll try to link: here

    ridesign

    @ridesign

    my database size is 200mb, do you think wordpress can not handle databases this size , or what do you recommend I should do?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: WP Tuner] What is running Slow?’ is closed to new replies.