WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: WP-TopBar] Top Bar Not Showing Up

[Resolved] [Plugin: WP-TopBar] Top Bar Not Showing Up

Viewing 15 replies - 1 through 15 (of 36 total)
  • Plugin Author Bob
    Participant

    @rfgoetz

    You have entered this script as your Link Text.

    <script src=”http://modules.idx.diversesolutions.com/modules/quick_search/ModuleScript.aspx?pid=ae2d405e-20f1-4b5b-b7e6-9697689bba2b”></script>

    That cannot be embedded in the TopBar HTML on your screen since it is embedded in the middle of a <a> tag. The plugin uses jquery to push the topbar on the page while the preview page does not use jquery.

    Bob

    thatwastaxing
    Member

    @thatwastaxing

    Not working for me either since the update. No HTML. It does work in the footer though.

    Same problem for me I’m afraid…

    pest control website

    Using v. 3.06. The pop-up shows great in preview, but is totally gone from site. Could this be a cookie-persistence issue?

    Plugin Author Bob
    Participant

    @rfgoetz

    Did you look at the FAQ or the Debug page?

    There is no TopBar HTML being generated on your page.

    You are using Caching plugin, did you clear your Cache after you changed the plugin settings? If not, your Cache is old.

    Yes, I looked at the FAQ. The debug page only suggests to individually test and remove CSS; that’s both impractical and not what I think is the central issue.

    TopBar is activated and is showing a preview.

    link to screengrab

    I cleared caching (several times).

    TopBar showed up once, then stopped.

    Could this be the culprit: If it finds a cookie and the cookie value matches the Cookie Value setting, it prevents the TopBar from showing.

    “If you change the Cookie Value to something new, the TopBar will show up again. This is useful if you want to force the TopBar to show on new content. Make sure to select something you haven’t used before. A good idea is to increment the value by one every time you want to force the TopBar to show.”

    While testing the plug in – and closing it manually – could I have changed the cookie value to prevent future loading?

    How does one change the cookie value? It is not clear that this is a function within the plugin.

    Plugin Author Bob
    Participant

    @rfgoetz

    For some reason, jquery is not defined on your website. I found that by looking at the Chrome Developer console:

    /about/integrated-pest-management/:105Uncaught ReferenceError: jQuery is not defined

    The plugin forces an enqueue of jquery — but for some reason it is not working on your site. You may have a plugin installed that is de-registering the WordPress default.

    Follow these steps to add jquery to your theme until I can figure out a long term solution:

    http://wordpress.org/support/topic/how-do-i-enqueue-jquery-in-my-theme?replies=6

    To change the cookie value, go to the Close Button tab. You will see “Cookie Value” as a setting.

    It it will help, here’s the current jQuery comment set from the functions.php:

    <?php
    function load_js() {
    	if (!is_admin()) {
    		wp_deregister_script('jquery');
    
    		// load the local copy of jQuery in the footer
    		wp_register_script('jquery', '/wp-includes/js/jquery/jquery.js', false, '1.3.2', true);
    
    		wp_enqueue_script('jquery');
    
    		// load JS files
    		wp_enqueue_script('selectbox', get_childTheme_url() . '/js/jquery.selectbox-0.5.js', array('jquery',), '0.5', true);
    		wp_enqueue_script('easing', get_childTheme_url() . '/js/jquery.easing.1.3.js', array('jquery'), '1.3', true);
    		wp_enqueue_script('bxslider', get_childTheme_url() . '/js/jquery.bxSlider.min.js', array('jquery', 'easing'), '1.0', true);
    		wp_enqueue_script('custom', get_childTheme_url() . '/js/custom.js', array('jquery', 'bxslider', 'easing'), '1.0', true);
    	}
    }
    Plugin Author Bob
    Participant

    @rfgoetz

    OptimalC, are you willing let me have admin rights to see if I can find a long-term solution? I don’t have the issue in the 1/2 dozen sites I’ve tested.

    Sure…how can I send you a pm?

    Plugin Author Bob
    Participant

    @rfgoetz

    Your paste above helped. I hacked a functions.php and may have found a long-term fix:

    In wp-topbar.php:

    Change this:

    add_action( ‘init’, array( __CLASS__, ‘wptb_enqueue_jquery’ ) );
    add_action(‘wp_footer’, array( __CLASS__, ‘wptb_inject_TopBar_html_js’ ), 15);

    to:

    add_action( ‘wp_enqueue_scripts’, array( __CLASS__, ‘wptb_enqueue_jquery’ ) );
    add_action(‘wp_footer’, array( __CLASS__, ‘wptb_inject_TopBar_html_js’ ), 9999999);

    Reply back to let me know if this worked.

    yes, i believe that did the trick. It’s showing up now.

    Plugin Author Bob
    Participant

    @rfgoetz

    Ok — I’ll push out a new version in a few days. Thanks for helping me fix this one!

    Thanks. Can your plug-in (does your plug-in) support multiple image banners? Perhaps serving up a new ad banner every “nth” visitor?

    Plugin Author Bob
    Participant

    @rfgoetz

    The plugin does not do that yet; it is in the features backlog.

    Plugin use to work fine until i updated to the new version. When i activated the latest version i found my top bar didn’t show. [note: when i’ve updated the plugin in the past it’s worked fine].
    i checked all settings and they were correct – the only thing that worked was to delete all settings then configure it again. However found if i set the ‘start delay’ for 30000ms the topbar stopped showing again, even changing delay to shorter time or even 0ms didn’t work – only fix was to again reset all settings and start again.
    I’ve got it to work BUT instead of the topbar pushing down my website when it shows it now shows over the top of my website header which is very annoying! Why the change here?? This is why i liked the plugin because it didn’t show over the top of your website.
    Liked the way it use to work 🙁

Viewing 15 replies - 1 through 15 (of 36 total)
  • The topic ‘[Resolved] [Plugin: WP-TopBar] Top Bar Not Showing Up’ is closed to new replies.