WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] [Plugin: WP to Twitter] WP TO TWITTER ERROR

[Resolved] [Plugin: WP to Twitter] WP TO TWITTER ERROR

  • wp version : 3.3.2
    WP to Twitter Version : 2.4.2

    All informations are given (Access level : Read and write)

    Consumer key / Consumer secret / Access token / token

    when i send de request on the WP pannel, I receve an eror :

    Your server time: Wednesday, 23-May-12 13:22:32 UTC Twitter’s time: There was an error querying Twitter’s servers..If these timestamps are not within 5 minutes of each other, your server will not connect to Twitter.

    Twitter requires authentication by OAuth. You will need to update your settings to complete installation of WP to Twitter.

    OAuth Authentication Failed. Your server time is not in sync with the Twitter servers. Talk to your hosting service to see what can be done.

    How can I fix it ?

    http://wordpress.org/extend/plugins/wp-to-twitter/

Viewing 15 replies - 16 through 30 (of 30 total)
  • It’s possible that you have a different issue than the rest in this list, Luke. Regardless, please try the new version released today; it includes a toggle to switch between whether you are making HTTP or HTTPS requests to Twitter. Additionally, if there’s a basic HTTP request error, it will report the text of that error, which would be helpful for me in any further debugging.

    Updated en seems to work now.
    Thanks for the good work!

    Hi Joe,

    When I switch off HTTPS requests to Twitter, your plugin works very fine here.

    Hi,

    I use bit.ly for url shorting on WP to Twitter 2.2.4
    My bit.ly api key is right enter but WP to Twitter display an error message:

    “The query to the URL shortener API failed, and your URL was not shrunk. The full post URL was attached to your Tweet. Check with your URL shortening provider to see if there are any known issues.”

    What’s wrong?

    Greetings, Bernd

    Hello!

    My site: http://www.alldattia.com
    Using a Windows Server, WordPress version 3.4.1, WP to Twitter version 2.4.5.
    Same issue. See below:
    *******
    Twitter requires authentication by OAuth. You will need to update your settings to complete installation of WP to Twitter.
    WP to Twitter Set-up

    Your server time: Friday, 06-Jul-12 17:51:16 UTC Twitter’s time: There was an error querying Twitter’s servers.If these timestamps are not within 5 minutes of each other, your server will not connect to Twitter.

    SSL Problems? Try switching to http queries.

    SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
    *******

    My other website: http://www.turista.com.br is working fine, at the same server, but in a different directory. Also WordPress 3.4.1 and WP to Twitter 2.4.5

    Thanks for trying to help us.

    Regards

    Angelo Marzolla
    http://www.alldattia.com

    Hopefully this can help. http://www.alldattia.com
    twitter.com/alldattia

    I just deleted the keys and secrets (XXXX)

    *********************
    Summary Connection Response:
    Array
    (
    [http_code] => 401
    [status] => 401 Unauthorized
    )

    Account Verification Data:
    {“error”:”Could not authenticate you.”,”request”:”\/1\/account\/verify_credentials.json?oauth_consumer_key=XXXXXXXXXXXXX&oauth_nonce=XXXXXXXXXXXXX&oauth_signature=XXXXXXXXX&oauth_signature_method=HMAC-SHA1&oauth_timestamp=1341601758&oauth_token=XXXXXXXXXXXXX&oauth_version=1.0″}
    Full Connection Response:
    jd_TwitterOAuth Object
    (
    [http_code] => 401
    [url] =>
    [host] => http://api.twitter.com/1/
    [format] => json
    [decode_json] =>
    [last_api_call:private] => http://api.twitter.com/1/account/verify_credentials.json?oauth_consumer_key=XXXXXXXXXX&oauth_nonce=XXXXXXXXXX&oauth_signature=XXXXXXXXXX&oauth_signature_method=HMAC-SHA1&oauth_timestamp=1341601758&oauth_token=XXXXXXXXXXXXXXX&oauth_version=1.0
    [http_header] => Array
    (
    [date] => Fri, 06 Jul 2012 19:09:18 GMT
    [status] => 401 Unauthorized
    [cache-control] => no-cache, max-age=300
    [www-authenticate] => OAuth realm=”http://api.twitter.com”
    [x-runtime] => 0.00315
    [content-type] => application/json; charset=utf-8
    [set-cookie] => Array
    (
    [0] => k=10.36.31.117.1341601758751315; path=/; expires=Fri, 13-Jul-12 19:09:18 GMT; domain=.twitter.com
    [1] => guest_id=v1%3A134160175875618329; domain=.twitter.com; path=/; expires=Mon, 07-Jul-2014 07:09:18 GMT
    [2] => _twitter_sess=XXXXXXXXXX–XXXXXXXXXXXX; domain=.twitter.com; path=/; HttpOnly
    )

    [expires] => Fri, 06 Jul 2012 19:14:18 GMT
    [vary] => Accept-Encoding
    [connection] => keep-alive
    [server] => tfe
    [content-encoding] => deflate
    [content-length] => 294
    )

    [sha1_method] => WPOAuthSignatureMethod_HMAC_SHA1 Object
    (
    )

    [consumer] => WPOAuthConsumer Object
    (
    [key] => XXXXXXXXXXXXX
    [secret] => XXXXXXXXXXXXXXXXX
    [callback_url] =>
    )

    [token] => WPOAuthConsumer Object
    (
    [key] => XXXXXXXXXXX
    [secret] => XXXXXXXXXXXXX
    [callback_url] =>
    )

    [useragent] => WP to Twitter http://www.joedolson.com/articles/wp-to-twitter
    )

    @angelomarzolla That second post looks like a test from attempting to connect with an HTTP connection – is that correct? When you switch to HTTP connections, do you still get an error message about the Twitter server time?

    Just my two cents: when trying to resolve this exact same issue, I tried to switch to http instead of https, and that solved it. So: secure is NOT working from my site, with a two minute time difference between Twitter and my webhost.

    I’m with skyhi on this. Changed from HTTPS to HTTP query and worked 1st time. It seems strange. Anyway back to work

    i have a domain and sub-domain. my domain is connected to twitter just fine for quite some time. attempting to connect my sub-domain to twitter and used this plugin and getting the error that my server not in sync with twitter, etc. i unchecked the https in twitter setting. nothing changed. i notified my isp of the sync error and they have not responded. i’m thinking they are not going to change their time. strange why domain works and sub.domain does not. both domains have successfully applied for respective applications. i am afraid to activate this plugin in my main site which is currently working.

    my isp said i can change time on server. i can’t find a good source on how to find the twitter time. i’m looking at dev.twitter forum. anyone on wp know answer?

    Thanks a lot! Yes, this worked for me.

    By the way, I am running the site on a Windows Server 2008 (WIMP).

    Here is what to do:
    Go to your WordPress dashboard and select “Settings” (at bottom on the left).
    Then click “WP to Twitter”.
    Now, the easiest way is to search for “HTTPS”. You should find a section called “Disable Error Messages”. In that section is a checkbox with “Switch to http connection. (Default https)”. CHECK THIS. Then, check “Save Advanced WP->Twitter Options.
    You should be good to go.
    If you found this useful and find this plugin useful, then you might also want to donate to to the author by following the great big “Donate” button at the top right.

    Have the same issue here with HTTP or HTTPS. Twitter time cannot be retrieved. Version: 2.4.11

    Is there some simple steps we can take to troubleshoot and narrow down the cause?

    e.g. From the command line I can connect to api.twitter.com with curl

    Or perhaps we can create a simple PHP file with a few commands in order to debug?

    Thanks!

    nvrmind

    Hi

    I have the same problem with the latest version.

    Disabling https makes it work. But can anybody explain to me if i now have security issues?

    Will this be fixed in the future releases?

    Thanks

Viewing 15 replies - 16 through 30 (of 30 total)
  • The topic ‘[Resolved] [Plugin: WP to Twitter] WP TO TWITTER ERROR’ is closed to new replies.