WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] [Plugin: WP to Twitter] WP TO TWITTER ERROR

[Resolved] [Plugin: WP to Twitter] WP TO TWITTER ERROR

  • wp version : 3.3.2
    WP to Twitter Version : 2.4.2

    All informations are given (Access level : Read and write)

    Consumer key / Consumer secret / Access token / token

    when i send de request on the WP pannel, I receve an eror :

    Your server time: Wednesday, 23-May-12 13:22:32 UTC Twitter’s time: There was an error querying Twitter’s servers..If these timestamps are not within 5 minutes of each other, your server will not connect to Twitter.

    Twitter requires authentication by OAuth. You will need to update your settings to complete installation of WP to Twitter.

    OAuth Authentication Failed. Your server time is not in sync with the Twitter servers. Talk to your hosting service to see what can be done.

    How can I fix it ?

    http://wordpress.org/extend/plugins/wp-to-twitter/

Viewing 15 replies - 1 through 15 (of 30 total)
  • You need to talk to your host. Your website is unable to communicate with Twitter. The fact that you’re seeing the message that there was an error querying Twitter’s servers means it’s not an OAuth or any other kind of plug-in problem — the time query is just a basic HTTP request to fetch the server current time at Twitter’s API servers, with no authentication of any kind. If your host can’t make that request, it won’t be able to succeed at any other request at all.

    The possible issues include having remote HTTP requests locked down on your server or your IP address or your hosting service being blocked by Twitter. However, there’s nothing I can do to help with this beyond telling you to talk to your hosting company.

    Best,
    Joe

    Same problem here.
    Strange is: WP to Twitter < 2.4 works fine.
    Has Twitter change API request?

    Greetings,
    Bernd

    Seriously? You’re able to query the server time using version 2.3.18 but NOT using 2.4.x?

    To be clear: I’m asking specifically whether you’re getting the Twitter time using 2.3.x and NOT getting it using 2.4.x.

    The reason I’m asking is because that query is *exactly* the same in the two versions: same methods, same query, etc. If it works in one version and not in another then that’s just weird.

    I can’t test it here, I have no backup from WP to Twitter 2.3.18. Sorry.
    It’s possible to send me this version?

    2.3.18 is now available from the WP to Twitter repository:

    http://downloads.wordpress.org/plugin/wp-to-twitter.2.3.18.zip

    Hm, I can’t activate the old plugin version.
    Error Message is: “Plugin can not activate. Fatal error”.
    Hm.
    I disconnect from Twitter before I try to install the old version.

    Ok, another trial:
    I use another (and older) WordPress -> Twitter Plugin:
    Name is Twitter Tools Twitter Tools and this plugin works without problems.
    It use OAuth too and I think, if this plugin works, HTTP request works also.

    Twitter Tools works 😉

    I try WP to Twitter v2.3.18 this afternoon.

    Thanks

    When i try to install wp to twitter v2.3.18 on my blog (wp version : 3.3.2), The activation is failed.

    L’extension n’a pu ĂȘtre activĂ©e, car elle a dĂ©clenchĂ© une erreur fatale.

    Parse error: syntax error, unexpected T_VARIABLE in /htdocs/wp-content/plugins/wp-to-twitter/wp-to-twitter.php on line 801

    Bye

    I’m following up with somebody else to try and track down why this connection isn’t working. It doesn’t make clear sense to me, since it’s an unchanged portion of the plug-in; but I’m continuing to investigate. I have not been able to reproduce the problem on any of my own dev site or any client sites who are running the plug-in, so it seems to be a fairly obscure issue.

    I certainly apologize to those of you affected by this issue — but all I can do for now is continue to explore it and try and find the issue.

    I’m having the same issue as well.

    Is anyone’s rss feed affected, too?

    I wonder if it has to do with the new version 3.3.2?

    Question: those of you having this problem. Are you on Windows servers, by any chance?

    Same problem here.
    I am on a Windows server.

    Thanks for the follow-up. I’ll have an update out to deal with this very soon.

    Ok, I ask my hosting service and the answer is: HTTP request is free and functional.
    I am on a 64 bit Linux server

Viewing 15 replies - 1 through 15 (of 30 total)
  • The topic ‘[Resolved] [Plugin: WP to Twitter] WP TO TWITTER ERROR’ is closed to new replies.