Support » Fixing WordPress » [Plugin: WP to Twitter] Tweet includes my custom text but not URL

  • I’ve installed you plugin and it seemed to work fine then after it an update it stopped. I’ve uninstalled and reinstalled several times. Here’s what’s taking place. I update my blog and it send the custom text I type on the post page but it never sends the url to click on?

    This is the setting I have right now for new post and edited post
    New post: #title# (#url#)

    Post Edited: #title# (#url#)

    I have the correct username in because like I said it sends the custom text but not URl. Any help or thoughts would be appreciated.


Viewing 13 replies - 1 through 13 (of 13 total)
  • You said that it ‘sends the custom text [you] type on the post page’ — have you noticed whether this problem exists only with custom texts, or is it a problem with tweets when you haven’t typed a custom tweet, as well?

    Hmmm. I’ll try it without the custom tweet and see. I usually always type a custom tweet so I’m not sure. I’ll get back to you. Thanks for your help…John


    It does post the url without the custom text. Any suggestions on how to get the custom text?

    Not offhand – but now I know where to look to help find the problem!

    I know this may be a dumb question, but are you actually including #url# as part of your custom tweet?

    Not a dumb question at all. I just type a custom tweet but I don’t provide a url. In the past it seems that I just typed the custom tweet and it sent the URL attached? Am I suppose to provide the url?

    thanks again for your help…John

    Another odd thing…and it’s probably at my end…I’m not sure.

    I checked the tweet that was sent. The shortened url and it throws an extra character in there. This is the link. The character was a “)” without the quotes. I double checked my username and API. Not sure….if it’s related or not?

    #url# is just the shortcode for adding the URL; this is a change in version 1.5. The only way to add the URL to a Tweet is to incorporate the shortcode – either in your custom tweet or in your Tweet default text.

    It used to be that if you had the option ‘add URL to Tweet’ checked, the URL would automatically be appended to the custom Tweet, but this has been changed in the latest version.

    I’m not sure where you’re getting the parenthesis – I followed the link from your Twitter account and I don’t see it showing up. ?


    I’ll add the url code to the custom tweet and see how that works. I must have missed the change in the newer version. Thanks for all your help..John

    I installed this plug-in because it seemed so much simpler than TwitterTools. The “tweet this” function seems to be working just fine, but the auto-tweet of all new posts to my twitter feed is not working, and that function is more important to me. I think I have all the settings correct, and just this morning I re-named the tt-config-sample.php to tt-config.php (d’oh!), but it is still not working. What else should I be checking?

    Thanks! I really do appreciate all the work that goes into developing and maintaining WP and its plug-ins.

    Yikes! I just realized that I’ve submitted my query in the wrong place, regarding the wrong plug-in. I was asking about TweetThis, and I see that this thread is for a different plug-in.

    My apologies. I’m off to investigate replacing TweetThis with WP to Twitter.

    I didn’t think that tt-config.php sounded familiar… 😉

    With the latest version, I think there is some confusion on the part of users… In the textarea on posts for putting in custom twitter text, it doesn’t include anything by default. This sort of makes sense, but I think non-techy people would expect the URL to get added by default.

    I customized the plugin a little bit to set the default template for each post in the textarea. In wp-to-twitter.php, part of function jd_add_twitter_inner_box, I added the following:

    if ($jd_twitter == ''){  // if we dont have a default set, give us one
    	$jd_twitter =  get_option( 'newpost-published-text' );  #"#title# - #url#";

    This will set the default template for posts. It should be clearer to users that they can modify this.

    Also, I thought the instructional text for this should say “shortened url” rather than “”, since some of us don’t use It would be swell if it could know what your URL format was.

    Great plugin, btw.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Plugin: WP to Twitter] Tweet includes my custom text but not URL’ is closed to new replies.