WordPress.org

Support

Support » Plugins and Hacks » WP to Twitter » [Resolved] [Plugin: WP to Twitter] Not saving: Do not post Tweets by default (editing only)

[Resolved] [Plugin: WP to Twitter] Not saving: Do not post Tweets by default (editing only)

  • In wp-to-twitter-manager.php I noticed that the post of the form does not get parsed right.

    if ( isset( $_POST['submit-type'] ) && $_POST['submit-type'] == 'advanced' ) {
    		update_option( 'jd_tweet_default', ( isset( $_POST['jd_tweet_default'] ) )?$_POST['jd_tweet_default']:0 );
    		update_option( 'jd_tweet_default', ( isset( $_POST['jd_tweet_default'] ) )?$_POST['jd_tweet_default']:0 );

    Seems to a duplicate line to me, if I add “_edit” to the second one the saving goes correct.

    Tho it does not disables it on the blogpost form.

    Is this setting build in correct or is it useful to spend some more of my time on this fixing it?

    Thanks for your reply 🙂

    http://wordpress.org/extend/plugins/wp-to-twitter/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Joe Dolson

    @joedolson

    So, this is kind of embarassing – I’d completely forgotten about that feature. It was supposed to be added in the last release, and I simply forgot to complete it. I hadn’t written it down on my to-do list, and it just got lost.

    So, there are a number of incomplete pieces to that, which I’ll have to take care of.

    Do you have any notes what to complete? Maybe I can help you out with completing this part 🙂

    Please let me know.

    Plugin Author Joe Dolson

    @joedolson

    Damn it! I just forgot to do this again. Why can’t I remember that this setting exists? Seriously. This is the 4th time I’ve released without even *thinking* about fixing this particular problem.

    Serious brain block on this one.

    Hi Joe,

    Have you had any luck fixing this feature?

    This would make the plugin much more useful as automatically tweeting everything by default could lead to some very widely distributed spelling mistakes!

    I will upgrade to the Pro version soon. Promise.

    Plugin Author Joe Dolson

    @joedolson

    Yes – this was fixed several months ago.

    Thanks Joe.

    I think I was trying to save it by hitting ‘Save WP->Twitter Options’ instead of ‘Save Advanced WP->Twitter Options’. As it wasn’t saving I assumed this thread applied to me.

    There’s no accounting for some people, eh?

    I just bought your pro version. Looking forward to taking it for a spin. I’ll try to RTFM before posting next time!

    Plugin Author Joe Dolson

    @joedolson

    Ah, yes – that will make a difference. Hope you enjoy the pro version! Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] [Plugin: WP to Twitter] Not saving: Do not post Tweets by default (editing only)’ is closed to new replies.
Skip to toolbar